Steam Segmentation Fault on startup

When I try to run steam, it doesn’t open up. When I ran it in the console I got this:[7395]: Running Steam on endeavouros rolling 64-bit[7395]: STEAM_RUNTIME is enabled automatically[7468]: Steam runtime environment up-to-date![7395]: Steam client's requirements are satisfied
[2024-05-02 14:38:50] Startup - updater built Apr 30 2024 22:32:46
[2024-05-02 14:38:50] Startup - Steam Client launched with: '/home/arthurzw/.local/share/Steam/ubuntu12_32/steam' '%U'
[2024-05-02 14:38:50] Opted in to client beta 'publicbeta' via beta file
You are in the 'publicbeta' client beta.
05/02 14:38:50 minidumps folder is set to /tmp/dumps
05/02 14:38:50 Init: Installing breakpad exception handler for appid(steam)/version(1714520927)/tid(7521)
crash_20240502143850_2.dmp[7524]: Uploading dump (out-of-process)
/home/arthurzw/.local/share/Steam/ line 813:  7521 Segmentation fault      (core dumped) "$STEAMROOT/$STEAMEXEPATH" "$@"
[arthurzw@arthur-gl75leopard10sdr ~]$ crash_20240502143850_2.dmp[7524]: Finished uploading minidump (out-of-process): success = yes
crash_20240502143850_2.dmp[7524]: response: CrashID=bp-11d4ac14-f0a9-4e51-963a-4eaa22240502
crash_20240502143850_2.dmp[7524]: file ''/tmp/dumps/crash_20240502143850_2.dmp'', upload yes: ''CrashID=bp-11d4ac14-f0a9-4e51-963a-4eaa22240502''

It also creates a .dmp file, but I don’t know how to open it. What other info do I need to provide to help figure out what the problem is and how I can get Steam to run again?

1 Like

I am dealing with the same error, I tried to reinstall steam and that did not fix it.

sudo downgrade glibc
sudo downgrade lib32-glibc
1 Like

Thank you!

Linking the regression discussion for anyone interested:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.