Steam pretends to start, but doesn't?

Hello all,

New to EndeavourOS, and I love it so far - but after installing steam, launching Steam caused the runtime update to occur… then nothing happened.

Running steam via terminal doesn’t show anything in particular, either - just goes through the routine runtime update check then… nothing. No login screen. It’s weird.

Any ideas?

Terminal dump:[3858]: Running Steam on endeavouros rolling 64-bit[3858]: STEAM_RUNTIME is enabled automatically[3932]: Steam runtime environment up-to-date![3858]: Steam client's requirements are satisfied
[pancake@ihop Desktop]$

Can you share the output of pacman -Q | grep steam

Only thing that outputs is this:


Hmm…you are using the normal steam package and it looks to have done it’s job.

Are there any crash details in the journal?

When you installed steam it asked you two questions for additional packages to install. Which did you select?

I didn’t receive any questions, actually, which I found odd, as the guide suggested I would be asked questions.
@dalto - not to sound like a complete novice, but I don’t have the faintest idea where to look for the journal.

Edit: if you mean bootstrap_log.txt, here it is:

[2022-04-01 07:58:03] Failed to load cached hosts file (File 'update_hosts_cached.vdf' not found), using defaults
[2022-04-01 07:58:03] Using the following download hosts for Public, Realm steamglobal
[2022-04-01 07:58:03] 1., /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2022-04-01 07:58:03] Verifying installation...
[2022-04-01 07:58:03] Unable to read and verify install manifest /home/pancake/.local/share/Steam/package/steam_client_ubuntu12.installed
[2022-04-01 07:58:03] Verification complete
[2022-04-01 07:58:03] Downloading Update...
[2022-04-01 07:58:03] Checking for available update...
[2022-04-01 07:58:03] Downloading manifest:
[2022-04-01 07:58:03] Downloaded new manifest: /client/steam_client_ubuntu12 version 1647446817, installed version 0, existing pending version 0
[2022-04-01 07:58:03] Package file missing or incorrect size
[2022-04-01 07:58:03] Package file missing or incorrect size
[2022-04-01 07:58:03] Package file missing or incorrect size
[2022-04-01 07:58:03] Package file missing or incorrect size
[2022-04-01 07:58:03] Package file missing or incorrect size
[2022-04-01 07:58:03] Package file missing or incorrect size
[2022-04-01 07:58:03] Package file missing or incorrect size

Run steam. Right after it fails, run journalctl -b

Skip to the bottom of the journal with an uppercase G. Then scroll up and see if there is output from a steam crash.

Doesn’t apppear to be anything related to Steam whatsoever, which is even more odd.

Is it running?

What does ps ax | grep -i steam return?

Looks like… it’s running? But the UI didn’t initialize?

   2056 ?        S      0:00 bash /home/pancake/.local/share/Steam/
   2185 ?        S      0:00 /home/pancake/.local/share/Steam/ubuntu12_32/steam
   5921 pts/0    S+     0:00 grep -i steam

Have you tried rebooting?

Yes, tried rebooting.

It looks to me like it is starting to start up but not complete its startup process.

It hasn’t crashed and is still running.

I am not sure how to troubleshoot that one.

Which guide?

Kill the running Steam processes (e.g. kill 2056), then run steam or steam-native in a terminal; this might provide more information.

1 Like

I’m getting the exact same error.

I just tried to kill the only 2 processes I could find for steam, and ran it again and got a different error. Hope that shed’s some light on the issue.

The two processes were;
24505 domarius 20 0 7952 4488 3564 S 0.0 0.0 0:00.01 bash /home/domarius/.local/share/Steam/
24646 domarius 20 0 54252 30628 11752 S 0.0 0.1 0:00.06 /home/domarius/.local/share/Steam/ubuntu12_32/steam

[domarius@domarius-endeavour ~]$ kill 2326
[domarius@domarius-endeavour ~]$ kill 2463
[domarius@domarius-endeavour ~]$ steam[24505]: Running Steam on endeavouros rolling 64-bit[24505]: STEAM_RUNTIME is enabled automatically[24580]: Steam runtime environment up-to-date![24505]: Steam client's requirements are satisfied
[2022-07-03 00:19:07] Startup - updater built Jun  7 2022 03:18:19
Installing breakpad exception handler for appid(steam)/version(1654574690)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

Yes that is the entire output, it hasn’t returned to a prompt.

Just updated, and Steam doesn’t start anymore (even after several reboots).
Identical issue as this thread Steam pretends to start, but doesn't? - #13 by dalto

[domarius@domarius-endeavour ~]$ steam[2481]: Running Steam on endeavouros rolling 64-bit[2481]: STEAM_RUNTIME is enabled automatically[2555]: Steam runtime environment up-to-date![2481]: Steam client’s requirements are satisfied
[domarius@domarius-endeavour ~]$

Do you get the exact same log output?

If so, why did you start a new thread if it’s the exact same issue?

And what packages did you update, specifically?

Sorry, I’ve updated the post to point to the correct thread. It’s the same output and the issue was never resolved. I guess if it’s recent enough it may be the same issue and worth posting there,

I go to reply and I get a warning about resurrecting a thread 3 months old. It makes me think it’s not the done thing here.

I’ll post there anyway, I got some different errors after trying what you said to do there.

Unless there is a way to recover a log for that information, that is lost to time. I just ran “UpdateInTerminal”.

You might want to flag this thread for merging or closure if you’ve started posting somewhere else.

/var/log/pacman.log and the output of paclog (if it is installed).