Steam not opening after updating

After updating my pc I am no longer able to open steam and it brings this up if I try to open it in the terminal

[organic@Computer ~]$ steam[3288]: Running Steam on endeavouros rolling 64-bit[3288]: STEAM_RUNTIME is enabled automatically[3361]: Steam runtime environment up-to-date!
/home/organic/.local/share/Steam/ubuntu12_32/steam-runtime/ line 85: steam-runtime-identify-library-abi: command not found[3373]: steam-runtime-identify-library-abi --ldconfig-paths failed, falling back to ldconfig[3288]: Can’t find ‘steam-runtime-check-requirements’, continuing anyway
tid(3404) burning pthread_key_t == 0 so we never use it
[2024-05-02 11:52:43] Startup - updater built Jan 13 2024 00:51:43
[2024-05-02 11:52:43] Startup - Steam Client launched with: ‘/home/organic/.local/share/Steam/ubuntu12_32/steam’
ILocalize::AddFile() failed to load file “public/steambootstrapper_english.txt”.
05/02 11:52:43 Init: Installing breakpad exception handler for appid(steam)/version(0)/tid(3404)
crash_20240502115243_2.dmp[3407]: Uploading dump (out-of-process)
/home/organic/.local/share/Steam/ line 798: 3404 Segmentation fault (core dumped) “$STEAMROOT/$STEAMEXEPATH” “$@”
[organic@Computer ~]$ crash_20240502115243_2.dmp[3407]: Finished uploading minidump (out-of-process): success = yes
crash_20240502115243_2.dmp[3407]: response: CrashID=bp-ead199cc-78a1-40e7-b363-e45b22240502
crash_20240502115243_2.dmp[3407]: file ‘’/tmp/dumps/crash_20240502115243_2.dmp’', upload yes: ‘‘CrashID=bp-ead199cc-78a1-40e7-b363-e45b22240502’’
[organic@Computer ~]$

here’s a picture of my steam folder bringing it up since a friend said a folder is missing.

1 Like

forgot to mention I did move my steamapps drive out of here and I am not referring to that folder

Check out this thread and please use code tags when posting the terminal output to help make it readable
BTW Hi and welcome to the forum

1 Like

Thanks for the fast reply but I don’t know how to downgrade it can you please explain how I can do it

If you haven’t cleared the cache folder then it should be easy to downgrade.
Here’s from documentation.

Thanks for the quick reply this fixed the issue really appreciate it!

1 Like

sudo downgrade PACKAGENAME


I am new to the forum, I was having the same issue and had to timeshift, how will we know when they have fixed the issue with glibc or the steam client?

According to this bug report, it’s been fixed as of 6 hours ago:

In the future, you can check for this yourself by going to the package on, then click on Bug Reports to the top right. Once it takes you to the page, click “All” to see all the bug reports and search for the issue you are having. See the images below for a visual example.


I tried the update again and it still seems to be broken on my end

Try updating your system fully, then reboot.

Better yet, after you update fully with one of the below commands, please post the output of your terminal.

sudo pacman -Syu

Scratch that. Never mind. The maintainers haven’t pushed the update yet. The package’s last update still shows yesterday.

Another update: You may need to reinstall the packages, meaning both glibc and lib32-glibc.
This is based on:

Update: This bug should be fixed now as they’ve pushed a new update a few hours ago after the bug itself was fixed. Now you can fully update your systems.


1 Like

Thanks ddnn, it worked


You’re welcome, and welcome to the forum! :vulcan_salute: :enos_flag:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.