Steam GUI won't launch

Hello everyone!

I am having trouble getting steam to properly launch. This has been a bit of an issue for the past week, but have always figured out the issue. I should mention that I am running an Nvidia card, as I suspect that to be part of the issue. I’ve checked that the Nvidia driver and utilities are up to date, tried both linux and linux-lts, even tried using testing repositories. Though none of this has worked, and steam still fails to load a GUI.

Nvidia versions:

lib32-nvidia-utils 535.54.03-2
nvidia-dkms 535.54.03-1
nvidia-hook 1.3-1
nvidia-inst 23-5
nvidia-installer-common 23-6
nvidia-prime 1.0-4
nvidia-utils 535.54.03-1
opencl-nvidia 535.54.03-1

I do find it odd that the lib32 utilities are newer than the non lib32 utilities, but that update fixed this issue yesterday. This behavior seems to be very unpredictable, but the furthest back I can track this issue is when Steam updated the app UI. If anyone has any ideas, please share. I’ll also be waiting for any updates that come through so hopefully that will fix this issue.

Here is the output of Steam if I launch from the terminal:[41258]: Running Steam on endeavouros rolling 64-bit[41258]: STEAM_RUNTIME is enabled automatically[41332]: Steam runtime environment up-to-date![41258]: Steam client's requirements are satisfied
[2023-06-22 10:54:23] Startup - updater built Jun 16 2023 01:41:16
[2023-06-22 10:54:23] Startup - Steam Client launched with: '/home/empyrean/.local/share/Steam/ubuntu12_32/steam'
06/22 10:54:23 Init: Installing breakpad exception handler for appid(steam)/version(1686880776)/tid(41395)
[2023-06-22 10:54:23] Loading cached metrics from disk (/home/empyrean/.local/share/Steam/package/steam_client_metrics.bin)
[2023-06-22 10:54:23] Using the following download hosts for Public, Realm steamglobal
[2023-06-22 10:54:23] 1., /, Realm 'steamglobal', weight was 1000, source = 'update_hosts_cached.vdf'
[2023-06-22 10:54:23] 2., /client/, Realm 'steamglobal', weight was 1, source = 'update_hosts_cached.vdf'
[2023-06-22 10:54:23] 3., /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2023-06-22 10:54:23] Verifying installation...
[2023-06-22 10:54:23] Verification complete

(process:41395): GLib-GObject-CRITICAL **: 10:54:23.421: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(process:41395): GLib-GObject-CRITICAL **: 10:54:23.421: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xf0c05db0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xf0c04500
GetWin32Stats: display was not open yet, good
Loaded SDL version 3.0.0-1735-g2e465ae31

(steam:41395): Gtk-WARNING **: 10:54:23.589: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Catppuccin-Mocha-Standard-Mauve-Dark/gtk-2.0/main.rc:790: error: unexpected identifier 'direction', expected character '}'

(steam:41395): Gtk-WARNING **: 10:54:23.590: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Catppuccin-Mocha-Standard-Mauve-Dark/gtk-2.0/hacks.rc:28: error: invalid string constant "normal_entry", expected valid string constant
GetWin32Stats: display was not open yet, good
ComputeStartupMode: found registry default startup mode: 0
Switching to desktopui, since -vgui was not specified[41404]: Runtime for steamwebhelper: defaulting to /home/empyrean/.local/share/Steam/ubuntu12_64/steam-runtime-heavy[41404]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
CAppInfoCacheReadFromDiskThread took 11 milliseconds to initialize
Failed to init SteamVR because it isn't installed

I don’t see why I would need this. I don’t use VR and Steam was working yesterday without it.

I’m having the same issue and also haven’t been able to fix it. I’ve seen a few suggestions that didn’t work for me, but maybe they will for you.

The first is to remove the xdg-desktop-portal-gnome package.

The other suggestion I saw was to run steam from the terminal with steam -no-cef-sandbox
This worked for a while, but stopped working after I updated the lib32-nvidia-utils package, though I’m not sure if that was the cause or not.

Finally, running steam from the terminal with steam -vgui runs it with the legacy GUI. This kindof works, but whenever I try to open a new window such as game properties, etc. the new window crashes.

Let me know if you find anything else that works!


I know this doesn’t completely help - but I have opted to run Steam as a flatpak for the last year or more so that everything is kind of one big package, and I’ve never had issues with it. It doesn’t really fix the issue, as much as it avoid it. . . but it may be something worth trying. The added “space” it takes up is worth the headaches for me.

1 Like

The steam -vgui flag seems to work perfectly fine. I just want to be able play my games. Thanks for the great reply!

For me uninstalling xdg-desktop-portal-gnome worked. No clue what that software does.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.