Steam games not working

Hi all!

My steam games have been glitchy for a while now. Steam itself runs completely normally, however whenever I open a game (except cult of the lamb. doesn’t work either but I think that might just be proton messing up), it glitches badly.

Like it’ll flash between Virtual Desktop 1, back to the game, lag, parts of my desktop environment such as my panel will show, and then fullscreen into the game again. Everything becomes mostly unresponsive, I can save myself by spamming Ctrl + Q. First time it happened with Portal and I switched to another TTY interface and rebooted lol. ALT F4 doesn’t work, for some reason it just takes a screenshot, even though that key is on F12.

Since it’s flashing like that and the resolution on portal with the in-game steam menu was kind of messed up, I’m guessing this may have to do with my GPU? It’s a GeForce RTX 4070 Ti, I wonder if something happened that steam and my GPU can’t talk to each other properly anymore or something.

We tried removing steam and all its data from my system, uninstalling all the games and reinstalling, and we tried installing protonup-qt and installing GE proton 7-9, I think. None of it really worked.

Anyone been having the same problem and/or knows a solution?

Did you try the flatpak version of Steam?

Thanks for the reply!

No, since the first thing I ever do on an OS is remove discover as it’s extremely buggy, and they don’t seem to work without it. My friend also recommended I not use flatpaks for larger things like steam.

How would switching to flatpak fix the problem? Genuinely asking from a place of curiosity, I’m not trying to be rude with that question. If there’s anything major using the flatpak could rule out and there’s a way to use them without discover I wouldn’t mind giving it a shot

ETA: I’m not even sure how to download it. Whenever I click the download button on the steam website, I just get a .deb file

EDIT: Okay so I found out how to use flatpaks without discover. Attempting to install

UPDATE: Nope, same issue. Was worth a shot I guess

What desktop environment and are you using Wayland or X11?

X11. We’ve tried Wayland too, I forgot about that, didn’t help. Nothing works on Wayland, not even discord. I have curse of Nvidia

edit: added “didn’t help”

Does it happen with native games or only proton games? Also try another window manager like i3 or openbox (if that works, your chosen desktop environment is probably causing the problem)

You’re likely right in your assumption that this is probably somehow related to nvidia…

Wait which nvidia drivers are you using? nouveau or nvidia-dkms?

Are you using the nouveau drivers? Or nvidia-dkms? The open source drivers tend to break more often.

I’ve been having issues with games too, like Portal 2 and Team Fortress 2.
Here are some things that helped my issues, but not in every scenario, I just try these and one of them tends to work.

  • Use flatpak Steam (fixed the Paradox launcher and some other weird issues)
  • Launch the game in Windowed mode. This option may be engine-specific, but for Source games I believe that adding -windowed to the Steam launch options should help.
  • Update my NVIDIA drivers.
  • Restart my computer, sometimes my games (specially TF2) only work once per restart for some reason.

I use i3wm and a GTX 1060, so some of these might not apply.

I’m sorry that these are not good fixes.

From my experience, I have done the following (RTX 3070 [Proprietary drivers - 555 beta] with Plasma 6.1 on Wayland, Steam installed through pacman):

  • Install proton runtimes manually before using in games (use the tools section in your steam library and search)
  • Check the games I want to play on ProtonDB to see other people’s settings
  • Installed dependencies (needed) for proton and steam (can be done by using pacman -Qi <package-name>
    • This one also reminds me that there’s a library that steam uses that doesn’t work and requires removal to use the system-native libraries. (I checked this by launching steam in command line with the -console argument to see what’s failing when launching an app.)
  • Having the multilib repository in your /etc/pacman.conf to make sure the 32-bit versions of packages required by steam are installed.
  • Installing drivers for OpenGL and Vulkan (since you’re running an Nvidia card, nvidia-utils and lib32-nvidia-utlis are installed if using Proprietary drivers and their equivalent for other drivers)

nvidia-lts. nvidia-dkms conflicts with what was already on my PC so we decided to not try that, I try not to muck with the nvidia stuff so much because I don’t want it to break again, I came here to endeavor after three failed attempts of debian.

I’ll have to look into openbox or i3. I’m just not sure why this is now suddenly an issue since everything has been working fantastically up until now

nvidia-lts is the package name, so neither, as nvidia-dkms conflicts with lts. Is nvidia-lts just the nouveau or a secret third thing.

I’ve sadly tried all of this, flatpak steam, windowed mode, nvidia drivers have been updated like twice since this became a problem, and my computer has been restarted so damn much recently due to trying to fix an issue with the fan LEDs xDDD

no worries! Thanks for the reply anyways :smiley:

i am on nvidia-dkms using the lts kernel though :thinking: have been for a good half a year or so. i don’t actually know what nvidia-lts is, but I would suggest you reinstall your nvidia drivers the way officially suggested for eos, using nvidia-inst to make sure your drivers are correctly set up in the first place.

1 Like

Not trying to be a party pooper here, but if you’re using Nvidia and mainly using your PC for gaming - it might be better to stick to Windows 10/11.

From what I’ve seen you’re going to face with this problem regularly/depending on what game you’re playing.


Is it dual graphics card? If so, please try to install nvidia-prime and add prime-run %command% into game settings within steam.

Also you may try to run your games with Lutris(triggers your steam games with proper configurations).

Check if the kernel parameter for the GPU is set. Use sudo cat /sys/module/nvidia_drm/parameters/modeset and see what it reports. If it was set correctly, it will give out Y as its output.

Absolutely not hahaha. Windows drives me crazy, I use it at work and school and had it on a VM a few days back because the Corsair iCUE software doesn’t work on Linux and I had to fix my LED lights, and it sucked so much. I prefer nvidia-linux compatability issues over the bloated security nightmare that is windows any day. It doesn’t even look good. It shows you ads.

I will go back to using debian with a nvidia card before I use windows, which I tried three times before I gave up xDDD

Turns out Y. I fixed a few games by just reducing the amount of virtual desktops I had lol. Some games still glitch though, I might try running steam in virtual desktop 1 exclusively since it keeps flashing to that.

1 Like

I think it’s a singular one, it’s a GeForce RTX 4070 Ti.

I’ll have to give Lutris a shot, been meaning to do that for a while

I used the “nvidia install” when setting up EOS, so I kinda assumed it would be set up correctly. I’ll see to try nvidia-dkms this weekend. How risky is this for my system? So I can back up files and brace myself for stress lol

It will be good to backup your stuff just because, but nothing should really happen. IIRC, nvidia-inst installs nvidia-dkms. If such issues don’t go away, it might very well be that support for your card is dodgy at best. I wouldn’t be surprised if these cards aren’t very well tested on Linux.

1 Like

What does

lspci | grep VGA