Steam games not using Nvidia GPU

I have just reformatted my computer to use EndeavourOS. I have installed the GPU drivers for my GeForce RTX 2060 using nvidia-installer and checked with nvidia-smi and nvidia-settings that the correct driver and version (460, which is the latest ATM) have been installed. However, when I fire up any GPU-intensive game on Steam things are ultra slow (2 FPS), and when I take a look at nvidia-smi and nvtop I see basically no GPU action, the only process using it is /usr/lib/Xorg. Plus, CPU usage goes through the roof. What should I do?

Run applications using the prime-run wrapper, e.g. in the Steam Launch Options:

prime-run %command%
1 Like

Also is this laptop with Optimus by chance?

Welcome btw :partying_face:

Nope, desktop running Intel® Core™ i7-8700 CPU @ 3.20GHz.

Try @jonathon’s suggestion

And just to be sure, please make sure you met all other requirements, especially vulkan, so we can exclude everything else except drivers.

For some the game doesn’t launch with this option. I’ll give it another shot later, gotta make lunch and babysit now. Thank you for the help!

Yes - a desktop CPU with an iGPU alongside a dGPU might still be picked up as a hybrid system? :thinking:

Do you have prime-run installed?

1 Like

Thank you, I’ll take a careful look. Abnd thanks for the warm welcome, I’m kind of amazed at how quickly a response came! :slight_smile:


Really, is that the thing now? :exploding_head:
I’ve never seen anything like it before…

It always has been. If not configured properly in the BIOS and there is an iGPU as well as a dedicated GPU it will be picked up as hybrid. Results vary from hardware configuration to configuration. mostly intel / nvidia.


Oh ok, that’s what you mean…

If that’s the case probably the best way is to:

  1. Disable iGPU in BIOS
  2. Reinstall drivers

Thank you for helping me debug the issue. Unfortunately, nothing has worked so far. I’ve tried:

  1. Installing nvidia-prime and running the game with prime-run %command%
  2. Switching the primary display slot from “AUTO” to “PCIE” (i.e., disabling the iGPU) in the BIOS
  3. Reinstalling the drivers

I really appreciate the help, but I have a hard time understanding why we should already be going as far as switching things in the BIOS. This is a run-of-the-mill, 3-year old Intel+Nvidia desktop I put together which has already gone through an Ubuntu and a Manjaro installation, both of which had pretty straightforward install-and-play gaming setups. I’ve gone through the docs and everything seems to be in order, but maybe I’m still missing some ovbious EndeavourOS package.

After some internet searching, I’ve found that the problem was with lightdm. No idea why, this is probably the last place I’d think of looking. Anyway, I’ve changed my Display Manager to GDM and everything works as it should, now.


WOW… :exploding_head:

Wonder what’s that all about, can you link some relevant information / lightdm bug reports for people who might came across this to dig more?

Sure, so this is the page that got me thinking that the problem could be lightdm:

And here are some instructions from the ArchWiki about getting Nvidia cards to work under any DM, (though it still did not work for me):