Steam Family Sharing Issue

Problem does exist on EndeavourOS as well. - Currently on Arch.

There are no useful debug logs I could find related to this issue.

tried using Steam-Native-Runtime/Steam/Steam flatpak:

I’m trying to share my games on the same computer with a secondary account, but whenever I reboot the PC, I lose access on the secondary account. The borrow button says to log into the main account and enable family sharing on the device.

When I go to re-enable the sharing on the main account, I see that the PC is still listed, and the secondary account is also listed, but when I re-check “Enable family sharing on this device”, it causes a second PC entry to appear, at which point, the sharing works again. Then, when I reboot, it happens again, and this continues repeatedly like this.

I am pretty sure that the issue is with steam itself. Family Sharing most likely is not designed to work with several accounts on the same machine, especially not when those accounts are used in the same (system-)user profile.

I ran this configuration on Ubuntu (Linux Mint, Zorin OS) and Windows just fine for over a year.
It is absolutely designed for this, as it uses some specific identifier for the machine as opposed to the user account. It’s stored in the steam files. This issue has only persisted for me on Arch and Arch-based distros. As far as I can tell, the issue is that the identifier being used is changing on reboot, but I can’t figure out what the identifier is. I sure as hell hope that steam isn’t using boot_id to identify individual machines.

  • If I log out of the account before a reboot, the same issue occurs. In fact, the original plan was to log out of the account and never ever log back into it, just leaving the shared games ready to play for myself. That was how I came to this conclusion in the first place.

If you want me to summarize in the most basic sense, the part inbetween the Borrowing and Lending halves of the family sharing function does not work properly on Arch. I really don’t know where to even begin with this. I did try to debug steam, but there was no useful info.

in this case you would be better of asking the question on the Arch forum.

I see nothing fancy being done in the way Arch(-based) installs steam:

Which means that the issue might be due to something that is being done in one or more of the “depends” - packages.

did already ask the question on the arch forum, just didn’t really expect anything because it was the arch forum if you catch my drift on that

i saw someone ask the same thing about 2 years ago and get completely ignored

I think this is a Steam issue (on linux), it ignores a few of the things I’ve set family sharing and the default start location - seems to only happen when I switch between online and offline though.

yeah, figured that out just a bit ago. steam linux issue

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.