Steam doesn't work. Bug or something else?

I installed Steam using “sudo pacman -S steam”, also enabled multilib on pacman.conf. When I click on Steam icon from Start menu, it shows runtime update then nothing. Checked on System Monitor, Steam process status shows NA.
If I run type steam on terminal it returns “Steam client’s requirements are satisfied”
But if I reboot and type “steam” on Terminal and press Enter, Steam opens up, all GUI loads up. Is it a bug or something else I did wrong ??

OS: Endeavour Cinnamon
GPU: NVIDIA GeForce GTX 1650
Kernel: linux-zen 5.17

Welcome to the :enos forums!!

It seems that steam is running now, so what is the issue?

Why I’ve to load Steam from Terminal ? Why can’t I click on desktop icon to run Steam.
Anyways I’m gonna try the flatpack version of Steam.

If you click the icon, does it work now?

1 Like

Tried flatpak version. It doest not work either.
Screenshot below:

What command is the desktop icon calling?

Maybe you can edit that command to the one that’s working in the terminal.

1 Like

Try steam-native-runtime that is the version I have always used in arch based distros that has worked best for me.

1 Like

Have a look…

Did it. But still hangs up. idk what i’m doing wrong

Lol it WORKED !!! Thanks a lot bro, you’re genius !!! :laughing:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.