Steam client crashing on launch

After updating my system via pacman today steam wont launch. Running it from the terminal shows it immediately getting a segmentation fault and core dumping. I’ve tried reinstalling the steam package with pacman -R but the problem persists. Below is the full terminal output of a launch and the gpu driver and steam versions i have installed

user@hostname:~ > steam[3683]: Running Steam on endeavouros rolling 64-bit[3683]: STEAM_RUNTIME is enabled automatically[3756]: Steam runtime environment up-to-date![3683]: Steam client's requirements are satisfied
tid(3807) burning pthread_key_t == 0 so we never use it
[2024-05-02 10:29:05] Startup - updater built Mar  6 2024 20:27:25
[2024-05-02 10:29:05] Startup - Steam Client launched with: '/home/user/.local/share/Steam/ubuntu12_32/steam'
minidumps folder is set to /tmp/dumps
05/02 10:29:05 Init: Installing breakpad exception handler for appid(steam)/version(1709846872)/tid(3807)
crash_20240502102905_2.dmp[3810]: Uploading dump (out-of-process)
/home/user/.local/share/Steam/ line 813:  3807 Segmentation fault      (core dumped) "$STEAMROOT/$STEAMEXEPATH" "$@"
user@hostname:~ > crash_20240502102905_2.dmp[3810]: Finished uploading minidump (out-of-process): success = yes
crash_20240502102905_2.dmp[3810]: response: CrashID=bp-45123707-3c41-4fb7-ba4e-c59f72240502
crash_20240502102905_2.dmp[3810]: file ''/tmp/dumps/crash_20240502102905_2.dmp'', upload yes: ''CrashID=bp-45123707-3c41-4fb7-ba4e-c59f72240502''
user@hostname:~ > pacman -Q | grep -e nvidia -e steam
lib32-nvidia-utils 550.76-1
nvidia-dkms 550.76-3
nvidia-hook 1.5-2
nvidia-inst 24-1
nvidia-settings 550.67-1
nvidia-utils 550.76-3

I’ve tried a few other solutions from similar issues i found in the forum such as launching with -vgui and -no-cef-sandbox params on the CLI but still see the same behavior.

1 Like

You should share the dump file too.

Also try using it works better usually. You launch it with steam-native it also has a dedicated menu icon.

1 Like

Just tried installing and running steam-native-runtime with what looks like the same results, the only diffrences i see are STEAM_RUNTIME being disabled and steam-runtime-check-requirements not running

user@hostname:~ > steam-native[7823]: Running Steam on endeavouros rolling 64-bit[7823]: STEAM_RUNTIME is disabled by the user[7823]: Can't find 'steam-runtime-check-requirements', continuing anyway
tid(7905) burning pthread_key_t == 0 so we never use it
[2024-05-02 10:51:35] Startup - updater built Mar  6 2024 20:27:25
[2024-05-02 10:51:35] Startup - Steam Client launched with: '/home/user/.local/share/Steam/ubuntu12_32/steam'
minidumps folder is set to /tmp/dumps
05/02 10:51:35 Init: Installing breakpad exception handler for appid(steam)/version(1709846872)/tid(7905)
crash_20240502105135_2.dmp[7908]: Uploading dump (out-of-process)
/home/user/.local/share/Steam/ line 813:  7905 Segmentation fault      (core dumped) "$STEAMROOT/$STEAMEXEPATH" "$@"
user@hostname:~ > crash_20240502105135_2.dmp[7908]: Finished uploading minidump (out-of-process): success = yes
crash_20240502105135_2.dmp[7908]: response: CrashID=bp-2ea2d092-204a-48fb-92b8-e3f542240502
crash_20240502105135_2.dmp[7908]: file ''/tmp/dumps/crash_20240502105135_2.dmp'', upload yes: ''CrashID=bp-2ea2d092-204a-48fb-92b8-e3f542240502''
user@hostname:~ > coredumpctl info
           PID: 7905 (steam)
           UID: 1000 (user)
           GID: 1000 (user)
        Signal: 11 (SEGV)
     Timestamp: Thu 2024-05-02 10:51:35 EDT (7min ago)
  Command Line: /home/user/.local/share/Steam/ubuntu12_32/steam
    Executable: /home/user/.local/share/Steam/ubuntu12_32/steam
 Control Group: /user.slice/user-1000.slice/user@1000.service/app.slice/app-org.kde.konsole-848b7b0fb6464619ab4874de06a60119.scope
          Unit: user@1000.service
     User Unit: app-org.kde.konsole-848b7b0fb6464619ab4874de06a60119.scope
         Slice: user-1000.slice
     Owner UID: 1000 (user)
       Boot ID: 309324ed370c408f9c1c9974b57a781a
    Machine ID: 57474088a89147cab8e6183c2d714089
      Hostname: hostname
       Storage: /var/lib/systemd/coredump/core.steam.1000.309324ed370c408f9c1c9974b57a781a.7905.1714661495000000.zst (present)
  Size on Disk: 12.7M
       Message: Process 7905 (steam) of user 1000 dumped core.
                Stack trace of thread 7905:
                #0  0x00000000e9c48348 n/a ( + 0xc348)
                #1  0x00000000e968665c n/a ( + 0x8665c)
                #2  0x00000000e9c3d53e _dl_catch_exception ( + 0x153e)
                #3  0x00000000e9c3d689 n/a ( + 0x1689)
                #4  0x00000000e96860e9 n/a ( + 0x860e9)
                #5  0x00000000e9686722 dlopen ( + 0x86722)
                #6  0x00000000e95ecd8e n/a ( + 0x27d8e)
                #7  0x00000000e95ef605 n/a ( + 0x2a605)
                #8  0x00000000e95ef706 glXChooseVisual ( + 0x2a706)
                #9  0x000000005a4c8afc n/a (/home/user/.local/share/Steam/ubuntu12_32/steam + 0x69afc)
                #10 0x000000005a493a70 n/a (/home/user/.local/share/Steam/ubuntu12_32/steam + 0x34a70)
                #11 0x00000000e9620b8f n/a ( + 0x20b8f)
                #12 0x00000000e9620c5e __libc_start_main ( + 0x20c5e)
                #13 0x000000005a498875 n/a (/home/user/.local/share/Steam/ubuntu12_32/steam + 0x39875)
                ELF object binary architecture: Intel 80386

What would be the best way to share the core dump? It doesnt look like the forums allow uploading a file over 6mb even if i change the extension to an allowed one.

cat /tmp/dumps | eos-sendlog and paste the link

But if it’s 6 mb it’s probably not easy to read, I also don’t know anything about nvidia, let’s hope someone else can help you. That /tmp/dumps file is 6 mb? Maybe it has old dumps too and steam just appends it. If that’s the case, you should delete it before running steam again.

This just means you’re using native and not the runtime provided by steam.

I was looking at the file listed by coredumpctl, /var/lib/systemd/coredump/core.steam.1000.309324ed370c408f9c1c9974b57a781a.7905.1714661495000000.zst which is 12.7mb. The one in /tmp/dumps is much smaller. I had to add .pdf for the the forum to allow posting but the file is unchanged, just delete the .pdf before opening.

crash_20240502105135_2.dmp.pdf (66.5 KB)

send the /tmp/dmps, it might be the same thing idk, but coredumps are hard to understand

I attached the latest coredump to my previous comment. I didnt cat the whole /tmp/dumps directory as there are several dumps in it.

I didn’t realize it’s a directory, try to find the one created by steam, if you sort by date it should easy. But it might be the same as the one you got from coredumpctl, in that case I don’t know enough to understand that, sorry.

Appears to be an issue with the latest glibc update. I downgraded glibc and lib32-glibc to the previous version and it works again.


That appears to be the issue @d-air1, downgrading those packages from 2.39-3 => 2.39-2 allows steam to launch. How did you figure out those specific packages were to blame?

1 Like

Combed through list of recently upgraded packages with paclog. I knew it worked fine yesterday, so only the most recent package updates could have broken it.

1 Like

had the same problem, and that solved it for me too.

thanks for the fast help!

Nice fix, thanks same issue on my system.


Also worked for me!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.