Steam Big Picture is not using my GPU

Hello everyone. I’ve been enjoying gaming on Linux for the past few months and I just found an issue that prevents me from streaming locally to my TV: Whenever I launch Big Picture, Steam does not use the GPU and the streaming runs at 15-20fps max… I tried streaming using a Windows PC and it went fine, so I don’t know what to do.

My computer specs are:
Ryzen 7 3700x
Nvidia RTX 2080s
32 GB ram

Try using prime-run steam or prime-run steam-native to specify running Steam on the dGPU.

zsh: command not found: prime-run

I don’t use Nvidia Optimus as my computer is a desktop plus my CPU does not have an integrated GPU

Then why do you way that


Doesn’t use the GPU for what?

To run Steam Big Picture. Games DO use the GPU, but not the big picture interface

What’s it using if not the GPU?

Could it be that for some reason Nouveau is used instead of the official Nvidia driver?

If that was the case then I’d expect performance issues in games.

@avgdd Could you post inxi -Faz (as text) please?

I guess it is running Big Picture on software, that’s why it is slow

  Kernel: 5.15.24-1-lts x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-lts
    root=UUID=07b9ce65-1e7a-4355-a2e4-c6f831fa2bf0 rw quiet loglevel=3
    nowatchdog nvidia-drm.modeset=1
  Desktop: GNOME 41.4 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-I GAMING v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 4602
    date: 08/17/2021
  Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 3165 high: 3968 min/max: 2200/4426 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3786 2: 3895
    3: 3733 4: 2066 5: 2105 6: 2106 7: 3910 8: 3928 9: 3770 10: 3679 11: 2088
    12: 2057 13: 3968 14: 2113 15: 3835 16: 3601 bogomips: 115191
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] driver: nvidia v: 510.54
    alternate: nouveau,nvidia_drm bus-ID: 07:00.0 chip-ID: 10de:1e81
    class-ID: 0300
  Device-2: Logitech C920 HD Pro Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1.2:4 chip-ID: 046d:0892
    class-ID: 0102 serial: <filter>
  Display: x11 server: compositor: gnome-shell driver:
    loaded: nvidia unloaded: fbdev,modesetting,vesa alternate: nouveau,nv
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: NVIDIA TU104 HD Audio driver: snd_hda_intel v: kernel
    bus-ID: 07:00.1 chip-ID: 10de:10f8 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0a:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Device-3: Logitech C920 HD Pro Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1.2:4 chip-ID: 046d:0892
    class-ID: 0102 serial: <filter>
  Device-4: Texas Instruments PCM2902 Audio Codec type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.3:7 chip-ID: 08bb:2902
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.24-1-lts running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.47 running: no
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    port: d000 bus-ID: 04:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: ASUSTeK
    driver: rtw_8822be v: N/A modules: rtw88_8822be port: c000 bus-ID: 05:00.0
    chip-ID: 10ec:b822 class-ID: 0280
  IF: wlan0 state: down mac: <filter>
  Device-1: ASUSTek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-8:6 chip-ID: 0b05:185c class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 1.84 TiB used: 689.16 GiB (36.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: N/A
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: RKT303.3
    temp: 28.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Crucial model: CT1000P2SSD8
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P2CR031
    temp: 42.9 C scheme: GPT
  ID-1: / raw-size: 953.36 GiB size: 937.32 GiB (98.32%)
    used: 689.13 GiB (73.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 27.7 MiB (5.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 8 GiB used: 2.2 MiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 39 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 41%
  Processes: 345 Uptime: 34m wakeups: 1 Memory: 31.33 GiB
  used: 4.39 GiB (14.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: 1220 pacman: 1213 lib: 340 flatpak: 7
  Shell: Zsh v: 5.8.1 running-in: gnome-terminal inxi: 3.3.12

According to the wiki Nvidia is blacklisting Nouveau anyway, so that should not be an issues.

Did you try running steam from the terminal and check the output when starting Big Picture?

I think “not using the GPU” is the wrong question, and that the key will be here:

Is the PC able to encode fast enough to maintain more than 20FPS? Have you checked CPU usage, and tried reducing the desktop and target resolution?

if you look at the screenshot in the opening post it shows a generic ‘Mesa/ 256 MB’ instead of the RTX 2080 in the system…

when using steam link over here on my pc, it correctly shows my Radeon RX 5600XT…

My guess is this is what was meant when OP said the GPU isn’t used

1 Like

This was kind of my question from before - what is it using if not the NVIDIA GPU, given the 2080 is the only output available? If it was using llvmpipe or something for software rendering it might make sense, but I don’t know why that would happen, unless it’s GNOME getting in the way, maybe it needs to undirect the window to disable the compositor? But even then, windowed applications will work just fine (e.g. games running in a window), so why would Big Picture be any different?

None of this makes much sense. I’ll have to test this out on my NVIDIA laptop.

None of this makes much sense.

I guess Steam is trying to be smart by not using the power hungry GPU and while it is supposed to fallback on iGPU, there is no such thing so it uses software render. (looking at you, Epic)

Try installing prime-run and running Steam with prime-run even if you have only 1 gpu.

1 Like

I finally gave up. I was not able to make this work. I also had some other issues with STEAM where some games that are supposed to be working fine with proton where not working at all. I did install Zorin OS and all these issues were gone all of a sudden.

I’ve really enjoyed daily driving EndeavourOS for almost a year, but unforntunately I don’t have the patience/time to deal with all these issues at the moment.