Steam 100% cpu usage issue

Hi!

I recently installed EndeavourOS + GNOME (new to linux) and got steam up and running. So far so good but sometimes (randomly) after I boot Steam or after it finishes a game download it remains in 100% cpu usage unless I restart it. Anyone else encountered this issue? If you need more info from me let me know.

1 Like

High CPU usage when downloading or installing is normal. Do you mean %100 on one thread or %100 on all threads?

it’s under 100% AFTER downloading is finished, or sometimes randomly after I boot steam for the first time (after reboot). And I checked only under the Gnome default Usage app and it showed 100%, don’t know if that’s under all threads or just one. I’ll try to find out next time it does this.

I got similar problem, all cores went 100% on idle, the whole system hanged and I needed to force reboot.

Turn out it was the damn Shader pre-caching, try to disable that in Steam settings

2 Likes

thank you! never would have guessed that ngl. I’ve disabled it and I’ll keep an eye on it.

1 Like

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

First post was a solution. Nice.

Pudge

1 Like

this setting while annoying at times significantly reduces shader compilation stutter in games so consider leaving it on. I generally let it finish which only takes a min or 2 on my machine but YMMV

1 Like

Came here to say that. Specifically, just make sure the “Allow background processing…” option is unchecked.

1 Like

I had same problem with same suggestion with same results of it being fixed. +1 for anyone else looking to solve this problem.

1 Like

I always leave them on, allow background processing as well, never had any issue until a few days ago and it didn’t go away. Will try to turn them back on later and see.