Startup Fail

I hope someone can help me with this issue:

On startup, system hangs at…

However, on third or fourth restart attempt, boot completes successfully to login screen.

System details:

Operating System: EndeavourOS
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.1
Kernel Version: 5.9.8-arch1-1
OS Type: 64-bit
Processors: 4 × Intel® Core™ i7-4510U CPU @ 2.00GHz
Memory: 15,5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4400


sudo blkid
# and
cat /etc/fstab
# and (you will probably have to install inxi):
inxi -Fxxxaz -c0 --no-host
# Rebuild grub & mkinitcpio:
sudo mkinitcpio -P
sudo grub-mkconfig -o /boot/grub/grub.cfg

Check your logs:

journalctl -b-1

That should do as a start :smiley:

Hi xircon

Thank you for your response.

I executed commands as suggested - all processes completed successfully.

Unfortunately the problem is not resolved.

See log report below:

From a learning perspective, would you mind giving me an idea of what you think has gone wrong with my system ( an HP Elitebook laptop btw).

Many thanks.

I’m no expert and don’t have a specific solution but when a boot hangs like this it is usually down to the fact that the graphics can’t be displayed, eg problems with the graphics drivers. Are you you using HP drivers or Open Source? Might be worth looking at those options. :smile:

your output is not complete and posting a picture of a log, is not very usefull, how could one do a reserch on it?

journalctl -b -1 | curl -F 'f:1=<-'

will make posting the journal from last boot easy as it will pastebin it to website and give a short URL you can post here.


Whoops! My apologies.

I didn’t realise the journal print-out was not complete.

Here is the pastebin link:

amd graphics not disabled:
Nov 17 09:11:02 hpelitebook sddm[572]: Failed to read display number from pipe

Nov 17 09:11:02 hpelitebook sddm[572]: Could not start Display server on vt 1
Nov 17 09:11:02 hpelitebook systemd-coredump[957]: Process 839 (Xorg) of user 0 dumped core.

Many thanks joekamprad.

I guess I should be embarrassed.

I took your referred cue from the journal log and started thinking…

I added a 16:9 monitor to my laptop a few weeks ago, so I had another look at my Plasma display settings.

Even though when I did have a successful boot, I thought display settings were OK because I would see the extended monitor only, as I wanted. (But for the boot problem)

In any case I revisited the display settings, disabled the laptop screen, and enabled the extended display and made it “primary”, and so far boot problem has not manifested again.

My apologies for taking up your time and of the others who made suggestions.

Many thanks.

Ok…so I am even more embarrassed. Took 4 reboots today to get my laptop up and running.

My lack of knowledge is exposed.

Going back to joekamprad: “amd graphics not disabled”

I did the following:

  1. Opened file " /etc/default/grub " (without quotes)
  2. Added " quiet splash radeon.modeset=0 " (without quotes)
    to line starting with " GRUB_CMDLINE_LINUX_DEFAULT= " (without quotes)
  3. Did sudo update-grub , followed by
  4. sudo reboot

Laptop booted successfully first time.

lspci -nnk | grep -i vga -A3 | grep 'in use'  reported Kernel driver in use: i915 (i.e. AMD Radeon successfully disabled.)