Starting laptop with lid closed and external monitor, getting no login screen

I moved from Manjaro to Endeavour OS on my work laptop today, primarily because I thought EOS looked very promising and because my old install was getting old and bloated with old config files and packages that I wasn’t using anymore.

Problem is that unless I am working on the go or am in a meeting, I never normally use the built in screen. Instead I connect my laptop to my thunderbolt 3 dock with the lid closed, and use only my two external displays. This worked fine in manjaro, but EOS doesn’t seem to like it. Specifically, the computer boots fine, but I never actually get to the login screen. Even if I open up the lid the screen will just be completely blank, not even a cursor. If I then enter a new TTY session and restart my display manager the login screen appears as normal and I can then close the lid again.

Some details: My laptop is a Dell Precision 5530, which has hybrid Nvidia graphics. However I have not configured the laptop to use the nvidia gpu at all. I am using GNOME, and thus the installer automatically installed GDM for me. However, I have also tried replacing it with LightDM (Webkit greeter) with the same result. I have also tried editing /etc/systemd/logind.conf and setting all three HandleLidSwitch, HandleLidSwitchExternalPower and HandleLidSwitchDocked to ignore, but that had no effect (the laptop doesnt seem to want to go to sleep anyway).

Its not a complete deal breaker, I can still use the laptop as I normally would if I first boot it with the lid open, but it is a bit annoying because I usually just place the laptop on a little shelf underneath the desk with is tall enough for decent airflow but not tall enough to have the lid open.

Has anyone experienced the same thing, if so, did you manage to fix it? Or does anyone have any tips?

@Froglich Welcome

Have you tried disabling Thunderbolt security for the dock? Just a thought?

try ARandR … make docked profile . Had similar problem with Mac bookpro. now if plug in it switch over

1 Like

another one i have used is this