Starting bluetooth service doesn't enable bluetooth under Gnome

I’m trying to turn bluetooth on in the CLI and I’ve noticed that simply starting the service with:

sudo systemctl start bluetooth

doesn’t work under Gnome. Bluetooth is still disabled in the Settings and no device can connect. I have to turn it on with the toggle in the top right in the settings to make it work.

Turning Bluetooth off with sudo systemctl start bluetooth works just fine.

Maybe I’m missing something obvious, any help would be appreciated.

Why do this, while you are using Gnome, which has no problem to enable bluetooth? Is it for testing, or you want to create an automation script?

You should check if this cli command is succeeding in other display environments (except Gnome) and if so, report this to Gnome developers as a bug.

Get bluetooth support (pipewire is default, or pulseaudio):

(https://discovery.endeavouros.com/bluetooth/bluetooth/2021/03/)

For pipewire:
sudo pacman -S --needed bluez bluez-utils

For pulseaudio:
sudo pacman -S --needed bluez bluez-utils pulseaudio-bluetooth

sudo systemctl enable --now bluetooth

^you must run this command for Gnome to even turn Bluetooth ON^

(bluetooth is wonky on Gnome 42 FYI so good luck!)

I go one step further to make sure bluetooth is ENABLED on login:

Fix bluetooth issues on reboot for Gnome 42: Auto power-on after boot/resume:

https://wiki.archlinux.org/title/Bluetooth#Auto_power-on_after_boot/resume

sudo nano /etc/bluetooth/main.conf

and uncomment AutoEnable and make sure it’s true, so bluetooth will be on by default. I’d try a reboot or two to make sure it sticks, but this is all I have to do for bluetooth to work as expected.

[Policy]

AutoEnable=true

i think this is since GNOME 42 ? it keeps BT of in the GNOME settings also it is enabled from the service…

@petsam correct, I need it for a systemd script to fix another issue.

@Scotty_Trees I had all those packages installed and bluetooth service was enabled, but I was missing that main.conf option. Looks like that did the trick and it’s working as expected now. Thanks a lot!

@joekamprad it’s possible it started with Gnome 42, I haven’t tried that on earlier versions.

Thanks to everyone involved for the support :slight_smile:

1 Like

Glad it’s working! I will note that on Fedora 36, in that main.conf file, they have that option set to true and on by default, so technically speaking bluetooth works better out of the box on Fedora. It’s off by default due to possible security concerns.

But just running one simple command allows you to be on the same page as one of the main Gnome distros and that’s something I try to replicate when I can on my EndeavourOS setup because I think for the most part, I like the sane defaults Fedora sets for its users.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.