Start automatic with fallback initramfs

Hi how can i set it so, that endeavours starts directly and automatic with fallback initramfs?
i am using EndeavourOS_Artemis_neo_22_7

Hi @sisqonrw, welcome to purple space!!
:rocketa_purple: :enos_flag:

You can try changing the boot order in grub:
here is an example:

But I would suggest you to do a simple web search on “changing boot order in grub”

@sradjoker shared the answer to your question.

However, I would say that if you need to boot into the fallback initramfs, it would be better to fix your initramfs. You may just need to add something to it.

What happens when you try to boot off the normal initramfs?

1 Like

Welcome to the forum @sisqonrw :enos_flag: :partying_face:

1 Like

open, install apps is very slow.

is there no easy way? i am newbie. is my second day of using endevouros. i just want that the system choose at start or boot the second option boot with “fallback initramfs”

That is the easy way.

edit /etc/default/grub and change one number. Then run sudo grub-mkconfig -o /boot/grub/grub.cfg

Should i change GRUB_DEFAULT=0 in 2?

I am not sure what the right number is, it depends on your specific system. Try 2 and see if it does what you want. If not, it should be obvious from there right the correct number is.

Another way to change grub entries is to set the following values in


and then regenerate grub.cfg as @dalto mentioned above.

This way makes grub remember what your previous selection was, and default to that.

Just be aware that this only works with certain filesystems.

For safety reasons, this storage is only available when installed on a plain disk
(no LVM or RAID), using a non-checksumming filesystem (no ZFS), and
using BIOS or EFI functions (no ATA, USB or IEEE1275). 

It also doesn’t work with anything that grub doesn’t have driver support for writing so no btrfs in addition to that list. I think there are a few other too.

I’m using it on ext4.

Yes, it works on ext4 and most of the other basic filesystems.

This way should work more generally:

GRUB_DEFAULT='EndeavourOS, on linux'
1 Like