Spotify suddenly wont launch anymore

Hi. Anyone else having the same issue in the past couple days with spotify-launcher from extra repository not launching anymore? I am pretty sure this occurred after an update I must’ve done. I can go without a lot of software, but Spotify is a bummer when broken.

Try spotify from other packages in the AUR or flatpak.

Personally I got fed up with the official app on linux, so I use spotifyd and control it from my phone, but you can also control it with cli programs like spotifyd works really well for me and only uses a few megabytes of ram unlike the official app.

I’ve never had an issue with spotify from the AUR.


Can you try to launch it from the command line and see if there are any error messages returned?

This is what it responded with

[2023-08-31T12:12:21Z INFO  spotify_launcher::config] Loading configuration file at "/etc/spotify-launcher.conf"
[2023-08-31T12:12:22Z INFO  spotify_launcher::apt] Downloading release file...
[2023-08-31T12:12:22Z INFO  spotify_launcher::apt] Downloading signature...
[2023-08-31T12:12:22Z INFO  spotify_launcher::apt] Verifying pgp signature...
[2023-08-31T12:12:22Z INFO  spotify_launcher::apt] Signature verified successfully!
[2023-08-31T12:12:22Z INFO  spotify_launcher::apt] Downloading package index...
[2023-08-31T12:12:22Z INFO  spotify_launcher::apt] Verifying with sha256sum hash...
[2023-08-31T12:12:22Z INFO  spotify_launcher::apt] Downloading deb file for "spotify-client_1.2.18.999.g9b38fc27_amd64.deb" version="spotify-client" ("1:")

(process:19625): Gtk-WARNING **: 05:12:22.980: Locale not supported by C library.
        Using the fallback 'C' locale.
This option is not available. Please see --help for all possible usages.
Error: Broken pipe (os error 32)

Curious who pushes updates of the official repository Spotify that I have installed? Is it the Arch team? The EnOS team? I’m not clear on how this all works. I know the AUR is user provided but the one I have I assumed was packaged and pushed by the EnOS team when coming from the ‘official repository’?

I’m trying hard to not have to switch to AUR or Flatpak. I’ll see if I can sort this out first before going down that route.

Something is wrong with your locale, and it’s preventing the application from launching. Please post the output of

locale -a
1 Like

What exactly did you install? There is no spotify provided by EOS.

Edit: Been using spotify for years from the AUR. It has always worked.

1 Like

He probably installed the spotify-launcher from the Arch repo.

Agreed. Should probably just install it from the AUR. The launcher is sort of like a package manager for spotify— it installs spotify in the user’s home directory and update it independent of pacman.

The package you installed from the official repo is not actually spotify. It is just a launcher program (written in Rust) that pulls from the apt repository (the software repo for Debian and Ubuntu-based distros). It installs spotify inside your home directory and allows you to update it without using pacman. It is a launcher program, that's all. On the other hand, the spotify in the AUR is just a `PKGBUILD` that allows Spotify to be built and installed using `makepkg` and `pacman` respectively.


I’ve briefly read through the PKGBUILD of the spotify in the AUR. It seems like both spotify-launcher and the AUR package pull from the same source.

At least it’s known to work. :wink:

I got this from that command


I installed this one.

Does this still mean I should switch to the AUR package or is there another way to sort that issue you spotted with my locale?

I’m not sure if this is related to the same issue or not, but when you mentioned locale, I thought to take a peak at the option highlighted in the image below because I remember seeing a list of mirrors sorted by countries and now this button doesn’t do anything anymore. I click it and nothing happens, no popup menu. Might be completely unrelated, but I thought I’d mention it since locale has to do with location and from what I remember the mirrors option does too.

@Kundalini Try to regenerate the locale files on your system first. Open /etc/locale.gen with your text editor and uncomment all the locales that you need. After that, run locale-gen as root.

Also run



echo $LANG

Check that the LANG variable is set to some utf8 locale. For the launcher to work, the LANG environment variable needs to be set to a locale that supports utf8.

Run reflector-simple from the command line. Does it launch? If it doesn't post the error messages.

@anthony93 I followed those instructions you provided. Here are the results I received. FYI, I used the locale en_US.UTF-8



Still no luck launching. What really gets me is how this occurred in the first place. Everything was working fine a week ago and suddenly after an update this must’ve happened. I surely didn’t purposely mess with anything in the system.