Spotify-launcher fails to download .deb, something wrong with spotify's repo server

Just downloaded and reinstalled EndeavourOS yesterday

Everything was fine until I hit a roadblock with Spotify-Launcher failing to execute spotify.

I ignored it and installed Spotify AUR, though the issue kept nagging me, partly because Spotify AUR has been unreliable in the past. So I tried spotify-launcher again, found out that you can run it from the CLI with -v flag, and in doing so I found out that the download from the server kept failing. Sometimes at 96%, sometimes at 1%, here is the output of the error.

If you visit their website and try to download the .deb with firefox the same issue happens:

It’s the .deb that is the issue

So my workaround to get the .deb was to use wget, wget will automatically retry a failed download and just fetch the missing bytes.

Ultimately the sure workaround for me was to restore ~/.local/share/spotify-launcher from a backup from 3 days ago and I am now happily streaming.

As for this error message, I’ve seen something like this before, some issue with HTTP 1.0 prematurely closing a stream. I ended up resolving the issue by forcing HTTP 2.0 protocol, not sure if this is the case for spotify deb repo server.

Not sure how to proceed, who do I report this bug to? Is this even a bug or is it just me? how do I rule myself out? anybody else having issues?

wait a burger flipping second! I just remembered (after I posted of course…) that I switched from using my ISP’s DNS to CloudFlares… could that be the cause?

I’ve running Spotify as a Flatpak for a while, I prefer that to the AUR package. Try running the Flatpak version of Spotify to see if it gives you a better experience?


Only one way to find out. Switch it back and see what happens.

Or, as @Cphusion already stated, try the flatpak. If you need help installing flatpak let us know.


1 Like

so I don’t know much about DNS, I flipped it back immediately after this realization, and waited… wasn’t sure for how long, I went out, and came back, tried again, and still no luck

I will give the Flatpak version a shot

1 Like

If a Chromium (-based) browser is already installed.

thanks for the suggestion, but Flatpak route went smoothly, I am considering just using flatpak for all GUI applications.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.