Spotify Connect

Hi All, Apologies if this has been added in the wrong location, if it is, I am happy to move it. I am trying to understand how I activate Spotify Connect in endeavouros kde please? On Manjaro and Fedora, when I installed spotify, it would automatically allow me to pick my sonos speaker, whereas in endeavouros, thats not possible.

I’ve checked the arch wiki and I’ve found the following article. I am just not too sure how to make the edits as per the guide.

I’am too much of a newbie to understand how to amend the iptable. Any advice on how to do this would be appreciated. Thank you for your time.

Edit: I fixed it. In firewalled you need to switch the configuration to Permanent. Then click the Services tab and add Spotify to the list of Services.

After this add two UDP protocols, one for 1900 and the other for 5353. Click on options and reload Firewalld. Then in the Runtime configuration, select spotify and Spotify connect should work without any issues.


Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Glad you solved your problem.

To help us out, if this is solved to your satisfaction, click on the Solution button on the bottom of the post that most helped you solve the problem. In this case it would be your Original Post.

This marks this Topic as solved and triggers the forum software to do it’s thing.

Again, welcome to the forum. :enos:




1 Like

Thank you for the welcome! Happy to be here and to learn.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.