Spellchecking in Plasma (solved)

This field does not allow me to select a language for the spelling checker. What else do I need to install? Additional German language packages for Plasma are all already installed.

Mine is also empty too on English language.

OK, not that I need a spell check, but I don’t like it when something is half-finished. I assume there is some module that needs to be installed, but which one? Ich habe meine Standardsprache schon installiert:

Spectacle refuses to record only the active window right now :frowning:

Click on spell check and then help and maybe you can figure it out?

Edit: I’m not actually sure where the spell check is used?

You need to install Hunspell (or another spell checker) and also the appropriate dictionaries for any languages you use.

2 Likes

I installed Aspell-ru and I have a choice of Russian language in the KDE settings.

I have only English language installed and Hunspell is installed. How & where does the spell check work?

I think you need to also install a dictionary - hunspell-en_US in my case.

2 Likes

I think i had done this before. You would think this should be something that is done automatically? :thinking:

That’s something to ask the devs here, I suppose.

I was more thinking on the KDE side.

Or them.

The solution is: install hunspell-de (in case of german), then the language is available for selection.

Thanks to all who have tried to help :slight_smile:

2 Likes

Yup, hunspell-(insert language) works.

Screen Capture_select-area_20201220012724

3 Likes