Spectre V2 Warning

Hello, I am recently received noticed this issue from running journalctl -p 3 -b gives me:

Mar 26 13:11:13 __ kernel: Spectre V2 : WARNING: Unprivileged eBPF is enabled with eIBRS on, data leaks possible via Spectre v2 BHB attacks!

Online resources I found leads to:

I do get this warning with 5.15 and 5.16 but not with 5.17 which is available in testing repo. You can try that → https://archlinux.org/packages/testing/x86_64/linux/

From https://www.phoronix.com/scan.php?page=news_item&px=Spectre-BHI-Linux-Mitigations

Notable with this pull request too is no longer defaulting to LFENCE-based Spectre V2 mitigations on AMD systems but rather the generic Retpolines implementation.
These changes were all merged this afternoon into Linux 5.17 Git mainline. The patches should also be backported to the various supported stable Linux kernel series and distribution kernels in short order.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.