Spectacle screenshot bug (rectangle selection)

Only way to avoid this annoying bug is to put delay when taking screenshot.

What is the problem?

Are you running X11 or Wayland and have you tried to switch between them to see if the problem is still there?

(BTW, I have moved the post from Pacman to Plasma, since spectacle is Plasam specific. :wink:)

I’m using X11.

If the system compositor is enabled, which you can check by entering the following in the terminal:

qdbus org.kde.KWin /KWin org.kde.KWin.supportInformation

It will look like this :

Compositing
===========
Compositing is active
Compositing Type: OpenGL
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) HD Graphics (ILK)
OpenGL version string: 2.1 Mesa 22.1.3
OpenGL platform interface: GLX
OpenGL shading language version string: 1.20
Driver: Intel
GPU class: Unknown
OpenGL version: 2.1
GLSL version: 1.20
Mesa version: 22.1.3
X server version: 1.21.1
Linux kernel version: 5.18.13
Direct rendering: Requires strict binding: yes
GLSL shaders:  yes
Texture NPOT support:  yes
Virtual Machine:  no
OpenGL 2 Shaders are used

In this case,
the removal of xf86-video-intel, then reboot can fix the issue.

It is known bug: https://bugs.kde.org/show_bug.cgi?id=376865

For me it stopped after I disabled most of my desktop animations.

edit: (If?) I remember correctly Kwin’s Fade Effect was the animation that caused this bug
Screenshot_20220724_184717

Compositing
===========
Compositing is active
Compositing Type: OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce GTX 1660 SUPER/PCIe/SSE2
OpenGL version string: 3.1.0 NVIDIA 515.57
OpenGL platform interface: GLX
OpenGL shading language version string: 1.40 NVIDIA via Cg compiler
Driver: NVIDIA
Driver version: 515.57
GPU class: Unknown
OpenGL version: 3.1
GLSL version: 1.40
X server version: 1.21.1
Linux kernel version: 5.18.13
Direct rendering: Requires strict binding: no
GLSL shaders:  yes
Texture NPOT support:  yes
Virtual Machine:  no
OpenGL 2 Shaders are used

No Intel there.

Will disabling compositor do any help ?

I don’t remember at what point this started happening, but it seems I’m not only one affected by this:
https://bugs.kde.org/show_bug.cgi?id=456548

I guess I just need wait, right?

Yes, I also experience this issue, but it happens randomly.

@PhoenixAwakened for me this happens every single time, only “fix” is set delay at least 1s.

Will disabling compositor do any help ?

No idea, I dont know what you asking me.

See this :


The above screenshot I took by disabling compositor, without any failure.

EDIT : Is there something to do with “Keep Window Thumbnail”, and changing it to never ?

1 Like

That worked!
Unchecked Compositing: Enable on startup then restarted PC. Cannot reproduce the bug.

How did you know turning that off will fix the issue? There are so many settings in KDE must be a reason unchecking this one made the bug go away.

1 Like

I am not expert by any means !

You shared that you don’t have intel in compositing, like I have.

Hence, I thought if we disable the compositor, then it might change the working a bit.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.