Spectacle doesn't obey system theme when launched via PrintSc

I am trying out KWin with LXQt.
I am using Breeze Dark theme.
Spectacle doesn’t obey system theme when I launch via PrintSc shortcut.

If I open it via terminal or via the menu it obeys the theme:

Any ideas on how to fix this?

What command do you have tied to your print screen shortcut?

The default settings in spectacle itself, configured via the configure button.

Where abouts is the theme located? If its in home it may be looking for it elseswhere

You are on the right track, I think LXQt and KWin themes are clashing a bit. Also, it seems this is an old KDE/Kwin issue that is patched in the full KDE desktop but probably not for LXQt/KWin.
https://bugzilla.redhat.com/show_bug.cgi?id=1754395
I solved the issue by mapping Meta+P to spectacle command inside LXQt shortcut settings.

1 Like