Spacebar key suddenly stopped working in texts

I am currently using EndeavourOS i3wm edition all was good until suddenly my space key stopped working, stopped working as in it won’t type <space> in texts. But at other places it works normally like space key in i3wm keybindings works for eg:- $mod+shift+spacebar works as it should, I also have GNOME DE so I tried it there space key was working there also in texts, shortcuts everything was fine there. So that means it is not an hardware issue. Now I am not sure if this is an issue with i3wm or EndeavourOS system itself. Also tried shutdown, rebooting, logout none worked. noticed a new thing that spacebar key works if pressed simultaneously with Altgr key.

I have no idea what an Altgr key is for - so perhaps post the output from inxi -Faz. I t might give one of us a clue as to where to begin troubleshooting! It does sound like a config setting somewhere though.

It´s for reaching 3. level on keyboard. For example the lower signs of the number keys.

I just use the Shift for that - but I suppose it might be different if you don’t have, maybe, separate function keys? Stuff like that is why I don’t even consider a keyboard with a lower keycount! At one point I was operating a system with an extra 60 keys on it (compose and layout keys mostly) so a standard layout is like driving a 6-sp manual compared to my 13-sp overdrive manual in my truck!
(no extra thought required)

first thank you all for responding and trying to help me.
the issue is solved now.
I had this line bindcode 321 exec --no-startup-id /usr/bin/brave in my config file I don’t know how but somehow it broke my space bar so I tried to replace it with this bindsym F7 exec --no-startup-id /usr/bin/brave and it works now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.