Source Engine games have no sound

Hey all,
I’m out of ideas so I’ll try posting here. Hopefully someone can figure out what’s wrong with my config.

I am running Latest EndeavourOS (arch: 6.5.9-arch2-1) with Pipewire (1:0.3.83-1) and Wireplumber (0.4.15-1) on Intel 10700kf and AMD Radeon 6700xt

pipewire and pipewire-pulse is running correctly.
Every other app besides source games have audio.
Source Engine games show up in qpwgraph but have no audio output.
I have tried setting environment variables:
SDL_AUDIODRIVER=alsa (also pipewire and pulseaudio)

I tried using apulse to re-wire from pulseaudio
I tried deleting wireplumber config

When i run snd_restart in tf2 console, the game freezes (crashes rather)

The game used to work fine with the same config before i reinstalled the os…

Tf2’s latest update has an issue with libtcmalloc, i had to manually replace it with another source game’s lib, but i don’t think that should be the problem.

have you inspected your journal to see what the issue could be?

maybe try typing
journalctl -g “pipewire” see if you are getting errors during the module loads.

Or does it need the 32 bit modules? Just a thought.

There aren’t any errors in the journal.

I have installed the lib32 pipewire, alsa, and libpulse packages. Still doesn’t work :frowning: