Sound stopped working


I am currently running a rather fresh install of the bspwm version of EOS. The audio was working just fine prior to today. However, it has stopped working all together for both speakers and headset. The only thing I did today was login to steam, install lutris, then open YouTube after which I noticed the sound wasn’t working. I then updated my system to see if that would help. Additionally, I dual-boot with Windows and the sound works over there.

In pavucontrol, I see Firefox under Playback and the meter is correctly bouncing to indicate volume and I believe it is set to the correct Output Device. I did not change any configurations in pavucontrol, I only observed it and everything seems correct.

I have also Googled and snooped around these forums but nothing has really solved this issue for me. Can anyone help me troubleshoot this?

Hardware info:
Boot log:

Please post the output of the following commands:

systemctl status --user pipewire.service

systemctl status rtkit-daemon

pacman -Qs | grep pipewire

systemctl status --user pipewire.service

● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; vendor p>
     Active: active (running) since Tue 2022-05-24 01:11:31 CDT; 54min ago
TriggeredBy: ● pipewire.socket
   Main PID: 744 (pipewire)
      Tasks: 2 (limit: 18808)
     Memory: 6.7M
        CPU: 40ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipew>
             └─744 /usr/bin/pipewire

May 24 01:11:31 Endeavor systemd[737]: Started PipeWire Multimedia Service.

systemctl status rtkit-daemon

● rtkit-daemon.service - RealtimeKit Scheduling Policy Service
     Loaded: loaded (/usr/lib/systemd/system/rtkit-daemon.service; disabled; vendor preset: disabled)
     Active: active (running) since Tue 2022-05-24 01:11:31 CDT; 56min ago
   Main PID: 751 (rtkit-daemon)
      Tasks: 3 (limit: 18808)
     Memory: 672.0K
        CPU: 10ms
     CGroup: /system.slice/rtkit-daemon.service
             └─751 /usr/lib/rtkit-daemon

May 24 02:07:08 Endeavor rtkit-daemon[751]: Supervising 6 threads of 4 processes of 1 users.

pacman -Qs | grep pipewire

local/gst-plugin-pipewire 1:0.3.51-1
    Multimedia graph framework - pipewire plugin
local/pipewire 1:0.3.51-1
local/pipewire-alsa 1:0.3.51-1
local/pipewire-jack 1:0.3.51-1
local/pipewire-media-session 1:0.4.1-2
local/pipewire-pulse 1:0.3.51-1
1 Like

Thanks for the reply!

It looks fine.
Please wait for other forum members to have a look in here and provide some ideas.

You could highlight the text you paste in and click on </> button.

1 Like

BTW, there have been many cases of audio issues in the past couple of weeks in regard to what media session manager is being used. In some cases switching from wireplumber to pipewire-media-session have resolved the sound issue. Check which one you are using.

Last night, upon reading this , I tried switching from wireplumber to pipewire-media-session. It didn’t work, unfortunately. When I stopped tinkering, I guess I left pipewire-media-session installed.

If you have pipewire-media-session installed, try moving away wireplumber’s old config files:

mv ~/.config/pulse ~/.config/pulse.orig
mv ~/.local/state/wireplumber  ~/.local/state/wireplumber.orig

Reboot and check.

1 Like

Executed both commands, both folders got renamed appropriately. Rebooted, still no sound :frowning:

Sorry to hear!
I am running out of ideas here :slightly_frowning_face:

Please standby for more input from other forum members!
Wish you good luck!

you check "Auto-mute " enabled ? just idea

Edit …

If the Mode is enabled, it can cause problems for multiple users:

It can be disabled by using alsamixer.

See for more.

To save your current settings as the default options, run alsactl store as root.
1 Like

Thank you @pebcak for trying to help resolve this problem. I will wait for additional suggestions.

@Shjim Inside AlsaMixer, auto-mute appears to be disabled.


I really needed to use sound with my system so I quickly dumped all of my my dotfiles onto a thumb drive and re-installed. Sound worked until breaking after mass copying the dotfiles to the new installation. I re-installed yet again and began meticulously copying my dotfiles over one at a time to try to determine exactly which one was breaking my sound.

I purposely didn’t copy over .pulse-cookie because everything else was working/setup how I needed after copying over all of my dotfiles again (except that one).

Perhaps .pulse-cookie is the culprit in some sort of way? I don’t know but everything is back to working for now. Will update thread if it somehow breaks again.

So, after my last post, my sound broke relatively quickly afterward. I hopped over to Fedora in hopes it would work there. Similarly, it worked post-install then quickly stopped working again for whatever reason. It would seem that right after installation the sound works but it soon breaks afterwards no matter where I go. Side note, sound didn’t work at all in Ubuntu. On windows, sound works 100% of the time so this isn’t a hardware issue.

Can anyone please help me troubleshoot this? I would prefer to stay on EOS but I need sound.

Have you tried the LTS kernel?

On my latest EOS install, I installed LTS as well as Zen. No sound at all–currently on 5.15.43-1-lts

My gut feeling tells me that this “sof-hda-dsp” has something to do with my problems. In AlsaMixer, sof-hda-dsp is what my card is listed as with Realtek ALC294 as the chip.

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: sofhdadsp [sof-hda-dsp], device 0: HDA Analog (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 1: HDA Digital (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 3: HDMI1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 4: HDMI2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 5: HDMI3 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0


The problem has to do with Windows putting the sound card into some kind of power-saving mode during reboot. Linux cannot wake the card from this state. Therefore, rather than rebooting from Windows into Linux, the user must shutdown the system before booting into Linux for sound to work.

For more information, google Realtek ALC294

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.