Sorry, no supported Nvidia driver found for your graphics card (id 8a52)!

Hello , I’m just came to arch based distro endeavouros yesterday :slight_smile: . But :frowning: I’ve got problem detecting my nvidia-graphics on endeavour os.
I’ve used

nvidia-installer-check program downloaded from nvidia-installer-dkms

when running check i’ve got
Sorry, no supported Nvidia driver found for your graphics card (id 8a52).

This is my neofetch

                                       CPU: Intel i7-1065G7 (8) @ 3.900GHz 
                                       GPU: NVIDIA GeForce MX230 
                                       GPU: Intel Iris Plus Graphics G7 
                                       Memory: 2139MiB / 15770MiB 

running lspci -k | grep -B2 "Kernel driver in use:" | grep -PA2 'VGA|Display|3D' gives me these output

01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX230] (rev a1)
	Subsystem: Dell Device 0979
	Kernel driver in use: nouveau

What should i do ?

In debian based, i’ve just used nvidia-detect and it detect nvidia driver as nvidia-driver and it worked , but in here i’m getting this error.
Please tell me what should i do?

Welcome to :enos: forums.

Your system seems to be a hybrid (2 cards). It would help if you could post the output of the below command.

inxi -Fxxc0z --no-host | eos-sendlog

The command will give you a link post it here.

Running it gave me this

Welcome to the forum @nothingnew :enos: :enos_flag: :partying_face:

1 Like

:hugs: Thank you for having here. I thought who cares for free. But as a metaphor of community Thank you all. Have a great day.

If everything works satisfactory, there is nothing to do, you can just continue using the Noveau driver.

Welcome to the forum!

I prefer as much as opensource version of things. I could just use Noveau driver. but my problem comes when installing like those deep learning libraries such as Pytorch or tensorflow, which requires cuda to be install .

If it is possible to install cuda in endeavour but using Nouveau , i’m happy to use Nouveau.

I see in debian i’ve used to get backward X11 display when i install proprietary nvidia driver but wayland on opensource.

I see nvidia have docker way of using nvidia driver but it have no docs for using it on arch based distro, if it is possible , i could just run those libraries in docker :slight_smile: .

What is the official driver for your GPU? You can probably find the proprietary drivers in the AUR.

nvidia-installer-dkms package is supposed to make it convenient to find your graphics drivers, but if it does not work in your case, you can still do everything it does manually.

This is my driver name

                                           GPU: NVIDIA GeForce MX230 
                                           GPU: Intel Iris Plus Graphics G7

I see Intel version if already installed. I dont know how can i find Mx230 graphics card.
and if i did find , would it only worked, i mean i want to run both, nvidia have only 2gb space, while ram have 16 gb.

I heard optimus and bumblebee, but never tried to manual install, i fear of break.

You need nvdia 470 driver so need add another repo

1 Like

aumm thankyou i found it on AUR

$ yay -Ss nvidia-470xx-dkms
aur/nvidia-470xx-dkms 470.94-2 (+41 14.40) 
    NVIDIA drivers - module sources

Now i’ve some confusions , like If i installed, would they be automatically loaded from my current-kernel.I’ve also another kernel lts, what if i ran those would they also work .
and if i install nvidia-470xx-dkms would i get that handy switch on that dropdown panel , kind of i used to get in ubuntu


or if not this

to get both into hybrid graphics, i wouldnt need to restart to change to different drivers and use both two in hybrid mode.

Thank you :slight_smile:

See you finally got the 470x drivers installed. You could have used the following command to check.

 nvidia-driver-supported-branches -a
1 Like

Hello I’ve just completed building , here i got output

NVIDIA card id: 1d11
Series 495: supported
Series 470: supported
Series 390: not supported
Series 340: not supported

what should i do ? also to achieve that above functionality.
Thank you :slight_smile:

It’s just a tool to check the driver support. You have installed the 470xx version from the AUR which is the proper way.

Edit: I’m not sure the above post is showing you on PopOS?

You might be able to use optimus manager to switch between Intel and Nvidia.

Hey thankyou i’ve now ran

yay -S optimus-manager

yay -S optimus-manager-qt

and now rebooting . Thank you :slight_smile:

I have a desktop with an Nvidia GTX1060 and i don’t really have many issues. It’s quite different with a lot of Hybrid graphics on some laptops.

Edit: Hopefully optimus-manager works for you.

Edit: Posted this because you are using Gnome i assume?

On there is

If you use Gnome or the Gnome Display Manager (GDM), there are a couple extra requirements to be able to use optimus-manager :

  • The default gdm package from the Archlinux and Manjaro repositories is not compatible with optimus-manager, so you must replace it with this patched version : gdm-prime (also replaces libgdm). The patch was written by Canonical for Ubuntu and simply adds two script entry points specifically for Prime switching. The package is otherwise identical to the official one.
  • Gnome launches Wayland sessions by default, which are incompatible with optimus-manager. To force Xorg sessions, You need to edit the file /etc/gdm/custom.conf and remove the # before the line #WaylandEnable=false.

Another quirk of GDM is that the X server may not automatically restart after a GPU switch. If you see an empty black screen or a black screen with a blinking cursor, try switching back to an empty TTY (with Ctrl+Alt+F5 for instance), then back to TTY1 with Ctrl+Alt+F1. See this FAQ question.

  • I removed current gdm
    pacman -Rs gdm
    and installed gdm-prime through aur
    yay -S gdm-prime

  • There was no custom.conf only custom.conf.pacsave was there , anyway , i created custom.conf
    uncommented WaylandEnable=false

This third option kind of unknown, Another quirk of GDM is that the X server may not automatically restart after a GPU switch tells me to go to tty, now after what ? :thinking:

Thank you , it is more hassle, thanks not to nvidia company i would never buy nvidia in my life and if got kids force them not to :unamused:

This is why i also will never get a hybrid laptop. I don’t care if it has Nvidia or amd. If it has more than one graphics chip i’m not buying it. Currently my Ryzen laptops using amdgpu are fantastic.

1 Like