[Solved] Zoom links open in firefox but not chrome

I’ve been having a weird problem where zoom meeting links don’t open in Chrome. I have the correct mime types set up and the corresponding Zoom.desktop file, and when I try to open a meeting link in firefox, it does launch zoom. However, when I try to open the same link in Chrome, nothing happens.

Any ideas on what might be causing this?

There is a Chrome extension for that:

Thanks… that does help in that it ensures a web link is always present. However, it doesn’t launch the desktop application. The issue for me is that the desktop application is launched through firefox (so the mime settings are correct), but not from chrome.

Hi
paru -S zoom

Hope that helps, no idea what browser if any it will use.


Data

Reisntalled… didn’t help, I’m afraid.

So why exactly would you always need to open a Zoom session via Chrome (and not via FF)? Can you expound on that question a little bit more?

Guessing you are aware, that there is a dedicated Linux app for Zoom?

Sorry if I can’t seem to cut through your nebulae… so tell us more precisely, what you exact predicament is, please.

Maybe, someone here can help you better than I seem to be able, as of yet.

https://support.zoom.us/hc/en-us/articles/201362593-Join-My-Meeting-via-Browser#:~:text=If%20you%20are%20using%20Google,not%20currently%20supported%20in%20Safari.

:man_shrugging:

Not sure, what you’re trying to tell the OP. I guess they are aware of that already?

Hi @ivanhoe

I tried zoom -h in prompt nothing happened except the launch of zoom.
So I went browsing after several google’s I came across the link, it works
with several browsers(untested by me) I thought it may help. I don’t know
of any settings within zoom myself, I guess there must be a way to do
settings.


Data

:v:
Okayze…

I’ve found this on askubuntu:

Maybe it could help.

@ivanhoe because I use chrome and not ff. Say I received a zoom link in my email / calendar that I have open in Chrome. I click the link to join the meeting. That would normally use xdg-open to launch the desktop zoom app. And from firefox, that’s exactly what it does (which means the mime types and desktop file are all correct - otherwise, it wouldn’t launch from ff). However, when I click the link from Chrome, nothing happens. Opening Chrome dev tools, the console logs that it’s launched an external app:

Launched external handler for 'zoommtg://[company].zoom.us/join?action=join&confno=1234....

But nothing actually happens; i.e. it doesn’t launch the desktop app. If I press the Launch button again, the same thing gets logged, but it doesn’t do anything.

I saw that, and tried the fix. But I think my issue is different as in my case, firefox launches zoom just fine.

Would it hurt using a second browser like Ff? I have researched your issue on the web and found multiple instances of people writing extensions for chrome because of that exact same issue. They existed for some time, but they all went extinct over a while.

Maybe Google doesn’t want it to exist, as they are on a war to own the web?

Then, why use chrome in the first place???

:interrobang:

I’d rather copy and paste link details into zoom than change browser. I’m always on Chrome, and don’t use firefox. I only installed firefox to test.

This definitely worked for me even two months ago. I’m guessing I must have accidentally denied permission for Chrome to launch zoom, and can’t find a way to clear it.

So, perhaps you could write a “personal” letter to Google, or dive deep into chrome-tags?

Check that on Protocol Handler chrome://settings/handlers or try reseting Chrome configuration.

1 Like

Just solved it. When I ran xdg-open “http://google.com” it showed some warning about kfmclient command not being found. Googling around, I saw that I was missing an env var. I needed:

export KDE_SESSION_VERSION=5

I put that in my ~/.xprofile and it worked.

Should note that I’m running i3wm, but with a minimal kde installation for the pretty windows, dolphin, etc.

2 Likes

Lovingly responded, I’m glad you solved it on your own, while taking our time and effort to help you out…

Did you change the thread’s headline as [Solved] ?

No need for this:
Just mark the post referencing the solutution (your own post in this case) as solution, the forum-software will then mark it as solved.

This is the proper way to do it on this forum.

Thanks.

I’d tried a few different things before asking for help here, and used some of the suggestions mentioned in this thread. @Triby 's extension is useful, and googling around about Chrome’s protocol handlers led me to the solution that I failed to find previously.

3 Likes