SOLVED: Windows 10 overwrote grub... Looking for a solution

EDIT: Thank you to anyone who took a moment to respond. I figured out what I had done wrong. I followed the installation for BIOS system instructions rather than UEFI. Grub is working again, though I’m sure I’ll have to fix it in the future should this happen again.

I’m pretty annoyed by this. I had a working dual-boot solution for several months until Windows 10 arbitrarily decided to usurp the bootloader. I tried following the instructions here:
The final step failed, something to do with grub can only install with blocklists. I attempted to install it to /sda rather than a specific partition. How should I proceed?

Also, I’m not married to using grub. If there’s a way to get Windows bootloader to respect the Linux install then I’m for that too. Thanks for the help.

The fix is just a case of reinstalling the GRUB bootloader.

The specific error message will be useful.

Try again. You can provide information from within the live installer environment you use to perform the boot loader reinstallation.

Windows don’t care ‘bout nothin’ but itself. chroot and grub-install is a quick and easy workaround.

1 Like

And you will want to learn this proceedure as it will most definitely happen again. Dual booting with windows and linux is always problematic.


The best way I know of to avoid Windows overwrite of Linux booting is to use rEFInd. As yet, I have not seen Windows manage to mess that up - and it would be even easier to ‘fix’ than grub should it happen. Check our wiki for install and use instructions - it will pick up the Windows install automagically on being installed…

I wrote the wiki entry, so am available for help if needed...
1 Like

Interesting. I’ll take a look at that. Thank you.

Might be as simple as resetting the boot order with efibootmgr -o. Windoze update may just be putting itself at the top of the queue.

Is Linux and Windoze booting from the same efi partition? As a bare minimum Linux should be in its own efi partition.

You should be able to boot into Linux manually from within your BIOS. From there fix your boot order.

If Linux boot option has been removed then re-instal grub.

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS --recheck