[SOLVED] Wifi via NetworkManager stopped working


I hope this is the right sub.

I’m using Gnome and NetworkManager.

Since I wanted to save cost, I tried to use my laptop running Endeavour as a Wlan-Hotspot while using the linux-wifi-hotspot package from the AUR. It worked quite well, so I wanted to quit my Wlan-option, but the customer service offered me to just leave it on but not charge me for it anymore.

So I disabled the Hotspot and tried to reenable normal Wlan-use again. But it doesn’t work. ip shows wlan0 configured and ready, but networkmanager in gnome-setting tells me “No Wifi-Adapater found”.

$ ip link show wlan0
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT group default qlen 1000
    link/ether d8:9c:67:22:c9:0b brd ff:ff:ff:ff:ff:ff

I’m not sure what happened here, some help would be very much appreciated.

Edit. Alright fixed it. The device was disabled in /etc/NetworkManager/NetworkManager.conf


Welcome to EnOS’ forum!