[solved] White screen after login

Just installed EndeavourOS from scratch, booted and logged in fine. Installed the deepin and deepin-extra groups, and adjusted lightdm to use the deepin greeter.

Rebooted, all good and I see the deepin greeter ready to login in. Login, and I get just a white screen with a cursor.

I found a thread in RebornOS that suggested this was an issue with the deepin-wm-chooser process, but was only showing in virtualbox environments. Any idea on what I could do to resolve this?

Have you tried installing another desktop environment? Because it might be possible to test whether the problem is Deepin specific.

only xfce which is the default environment (that works fine). There is a white screen but goes away fast

Ok, I’ve tried budgie and gnome and they give the same problem

Have you tried it with GDM? I just installed it next to my Gnome install and there’s no white screen.

GDM install didn’t solve anything. Will try again from scratch

Which GPU are you using?

Intel UHD 630. It’s odd that only XFCE works for me, Budgie/Gnome/Deepin all give a white screen after I login

The thread is a year old, but maybe this workaround still works:

I have no problem seeing the login screen. The issue comes after the login screen. Once I login I see a white screen and cursor, and only XFCE continues beyond that point

This describes what I experience (but I’m not in VirtualBox)

Okay, f you’re still up for it follow the steps in this thread:

You can find the august release over here:

https://github.com/endeavouros-team/ISO/releases/download/1-EndeavourOS-ISO-releases-archive/endeavouros-2019.08.17-x86_64.iso

Thanks, I will try tomorrow after work

If you’re patient you can also wait for friday, then the November ISO will be released.

1 Like

That might be plan c :grin:
Given that XFCE works I at least have a usable laptop

1 Like

Using the August release solved the problem.

2 Likes

That is good news.

1 Like