[SOLVED] Wayland and Viber

Can someone else running Wayland/Plasma please check Viber? I get:

[onyx@onyx-laptop ~]$ viber
qt.qpa.wayland: Failed to load client buffer integration: "wayland-egl"
qt.qpa.wayland: Available client buffer integrations: ()
qml: CALL_WEB_VIEW_DEBUG: callWebEngineLoader active: false
failed to acquire GL context to resolve capabilities, using defaults..
qml: *** popupMode = 1920
Segmentation fault (core dumped)
[onyx@onyx-laptop ~]$ 

The only “help” I found online was an unsolved Manjaro thread of the same issue.

I can try it. I have Wayland running right now on Plasma. Do you have wayland-egl installed? Do you have Nvidia graphics?

1 Like

Yes+yes :smiley: thanks

I have it installed but when i launch it nothing happens. No error nothing. I’m going to try it from the terminal. Same error. I don’t have Nvidia on this computer and that file is something for nvidia.

[ricklinux@eos-plasma ~]$ viber
qt.qpa.wayland: Failed to load client buffer integration: "wayland-egl"
qt.qpa.wayland: Available client buffer integrations: ()
[ricklinux@eos-plasma ~]$ 
1 Like

Actually it say’s egl-wayland is for nvidia so now i’m not sure?

Thanks, so Viber is broken for Wayland/Plasma. Works fine under x11/Plasma, x11/Cinnamon.

It’s probably expecting wayland-egl, but isn’t built properly for the current version or something ? Viber always very slow with their Linux desktop integrations.

1 Like

Well there’s always Skype maybe?

Edit: I have been running Wayland on KDE Plasma on EndeavourOS all day and it works pretty well. Very responsive and fluid. Don’t see too much difference than on X11.

I’m pretty certain I’ve seen a thread recently about overriding the session type between Wayland and XWayland… :eyes:

I suspect you can override the session type for this application so it will use XWayland… :thinking:

Here: https://wiki.archlinux.org/index.php/Wayland#GUI_libraries, e.g.:

3 Likes

10 years ago, before the mickeySoft take-over, maybe…
I’ll just have to tell the family that I cannot fix their computers anymore, because they cannot get hold of me on Viber anymore, because Viber doesn’t want to work with a modern operating system…sounds like a good-enough excuse? :wink:
Yes, Wayland certainly feels snappier, and the main reason I was holding back (Remmina) seems to be fixed now.

1 Like

Verily Thou Rocketh.

[onyx@onyx-laptop ~]$ QT_QPA_PLATFORM=xcb viber
qml: CALL_WEB_VIEW_DEBUG: callWebEngineLoader active: false
qml: *** popupMode = 1920
qrc:/QML/DebugMenu.qml:248: TypeError: Cannot call method 'isIdentityChangeNotificationsEnabled' of undefined
qrc:/QML/DebugMenu.qml:314: TypeError: Cannot call method 'isWasabiEnabled' of undefined
qrc:/QML/DebugMenu.qml:341: TypeError: Cannot call method 'isOOABURISpamCheckerForceEnabled' of undefined
qrc:/QML/DebugMenu.qml:348: TypeError: Cannot call method 'isBirthdayNotificationEnabled' of undefined
qrc:/QML/DebugMenu.qml:355: TypeError: Cannot call method 'isBirthdayChatListEnabled' of undefined
qrc:/QML/DebugMenu.qml:369: TypeError: Cannot call method 'isVideoGroupCallEnabled' of undefined
qrc:/QML/DebugMenu.qml:376: TypeError: Cannot call method 'isForceASForScreenSharingEnabled' of undefined
qrc:/QML/DebugMenu.qml:384: TypeError: Cannot call method 'isRateCallQualityForceEnabled' of undefined
qrc:/QML/DebugMenu.qml:391: TypeError: Cannot call method 'isCreateCustomPackEnabled' of undefined
qrc:/QML/DebugMenu.qml:399: TypeError: Cannot call method 'isMyNotesForceEnabled' of undefined
qrc:/QML/DebugMenu.qml:413: TypeError: Cannot call method 'isTranslateMessageDeskManualEnabled' of undefined
qrc:/QML/DebugMenu.qml:420: TypeError: Cannot call method 'isTranslateMessageDeskAutomaticEnabled' of undefined
qml: Current screen: XWAYLAND0 [1920, 1080, 1]
qml: Geometry: mh=402, mw=282, h=402, w=282
qml: Current screen: XWAYLAND0 [1920, 1080, 1]
qml: Geometry: mh=190, mw=240, h=190, w=240
qml: Current screen: XWAYLAND0 [1920, 1080, 1]
qml: Geometry: mh=0, mw=0, h=0, w=0
qml: Current screen: XWAYLAND0 [1920, 1080, 1]
qml: Geometry: mh=46, mw=296, h=46, w=296
qt.gui.icc: fromIccProfile: failed minimal tag size sanity

1 Like

Guess this means the family will keep on calling :frowning:

1 Like

You have it working now? How?

Edit: I see above okay. Does that mean launching it from the terminal only?

As @jonathon pointed out, by setting the right environment variable beforehand, it works. So I edit my menus with Viber in them to launch:

QT_QPA_PLATFORM=xcb viber %u

Right-click the Plasma launcher, Edit Applications, Internet, Viber, change the command line, Save

1 Like

Did you have to install the qt5-wayland?

Yes, but I had already done that previously, though not sure why…it was there in the system anyway. Then I saw the other thread here about Plasma + Wayland, and thought it was time to give it a whirl, and that required the wayland egl for my nVidia chipset.

1 Like

Are you able to launch viber from the plasma launcher? It’s not working for me same errors.

Edit: Okay i got it working. I had to reboot but this desktop doesn’t have the camera. So i could put it on my laptop now if i want.

1 Like

Yes I am. I also turned it into a widget on the panel.


Left is the Widget’s properties, right is the Menu editor

Very nice. I like the desktop. Is it latte dock and panel at the top?

Exactly.

1 Like