[SOLVED] Vivaldi after waking

For me, Vivaldi stable 3.4 is suffering severe graphical glitches after waking from laptop suspend. It requires closing and reopening. I have opened a bug report with them, after clearing my profile and finding it was still at issue.
Is anyone else experiencing this?

To be honest if you’re done using your browser and are going to close the lid of your laptop you should shut down your browser completely. I don’t even allow it to run in the background in the systray.

Vivaldi-snapshot works flawlessly.

Why? I tend to use my browser as long as I use my computer, wich is most of the time.

There is a setting (can’t find it now) that determines what happens when you close the lid. I think it’s in energy settings.

There is, at least in Plasma. I’ve set mine to “do nothing” while plugged in, and “sleep/hibernate” if it’s running on battery.

Vivaldi stable 3.4 works fine here after awakening from suspension.

inxi -CG

CPU:
Info: 8-Core model: AMD Ryzen 7 4800U with Radeon Graphics bits: 64
type: MT MCP L2 cache: 4096 KiB
Speed: 1397 MHz min/max: 1400/1800 MHz Core speeds (MHz): 1: 1397 2: 1397
3: 1397 4: 1397 5: 1397 6: 1396 7: 1397 8: 1397 9: 1397 10: 1395 11: 1397
12: 1397 13: 1397 14: 1397 15: 1397 16: 1397
Graphics:
Device-1: AMD Renoir driver: amdgpu v: kernel
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
Display: x11 server: X.Org 1.20.9 driver: amdgpu,ati
unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.11-zen1-1-zen LLVM 11.0.0)
v: 4.6 Mesa 20.2.3

Thanks. Found this report here too:


So it would seem the commonality being use of nVidia with Vivaldi and resume from suspend = problem.
I’ll try some more variables soon.
1 Like

I can confirm; nVidia is the issue, or the way that Vivaldi interacts with the nVidia Linux driver. Under Intel on the same machine there is no problem; I have been using the nVidia GPU more lately because I have been running an external HDMI monitor, and that is only possible through the nVidia GPU on this laptop.

So I will confirm this finding to the bug tracker at Vivaldi, and see if there is a change in the settings that they can recommend.

2 Likes

Further to this;


and the discovery that VV Snapshot 3.5 in the AUR is fine; therefore it is a Chromium bug;

and the version of Chromium in the 3.5 VV is fixed for this issue.

Hi,

Thanks for reporting this issue.

There is a known issue on Chromium side so we decided not to do anything for this at this stage as it is not a bug on us.
Here is the link in case you would like to follow up.
[https://bugs.chromium.org/p/chromium/issues/detail?id=1001851&q=hibernation%20linux&can=2
]
You can check if disabling ‘Use Hardware Acceleration when Available’ (via Setting > WebPages) setting can work this around or not.

Hope this helps.
Thank you for your time writing us this report and for using Vivaldi!

Best,

Akira Hojo
Team Vivaldi

1 Like

And yes, turning Hardware Acceleration off works for me too.

3 Likes