[SOLVED] Vim/Neovim not opening in Alacritty

So first post here, I have been using Endeavour OS for a while now and I love its simplicity and ease of use while bring the power of Arch with it.

However, I have run into a very, very small annoying problem of which I cannot seem to find a solution online nor on this forum while scouring it.

So I have Vim and Neovim as shortcuts in my Whisker Menu, and I have set alacritty as my default terminal through Default Application.

But when I try to click any of the two I get an error:


And I have no clue as to why it does this nor can I find a solution for this. Also, when I choose alacritty I see like a “:no_entry_sign:” icon… but when I spell out Alacritty with a capitol A it does show the icon like it does with other terminals, but then I get this error:


And even though everything else works fine and such and of course I can just open the terminal and typ in vim or neovim to start these applications, I just want it to simply work haha

So I hope anybody can help me with this very small “problem”.


What I have tried myself to “troubleshoot” is to set it the path to usr/bin/alacritty but that doesn’t work as well unfortunately. I will still get these error and “:no_entry_sign:” sign.

Open a terminal, type alacritty press enter and post any errors.

alacritty opens up like normal (in a new window) when I use the Xfce Terminal. No errors or whatever, works like it is supposed to.

So the shortcuts are the problem. Try this in /usr/share/applications

[Desktop Entry]
Exec=alacritty -e nvim

Comment=A cross-platform, GPU enhanced terminal emulator


[Desktop Action New]
Name=New Terminal

Copy and past the above and call it mynvim.desktop, then try it from the whisker menu.

The icon will not work, but leave for time being. Or change to just say Icon=utilities-terminal

When I execute the mynvim.desktop simply by double clicking the file in /usr/share/application nvim will open correctly in alacritty.

So make it a favourite in whisker menu and remove the old shortcuts.

I succesfully applied your solution! I correctly edited the correct icons with my Papirus-Dark icon folder and gave them the proper names and both now work via Favorites in the Whisker Menu!
Also deleted the old vim.desktop and nvim.desktop files and replaced them with mynvim.desktop and myvim.desktop respectively.

Much obliged! :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.