[Solved] Updating i3

Hello! I wanted to use a feature from i3 called “i3-save-tree”, but I’m getting an error when I try to use it. i3’s website claims it’s a feature that was “introduced in i3 v4.8”.

Here’s what my terminal outputs:

$ i3 -v
i3 version 4.22 (2023-01-02) © 2009 Michael Stapelberg and contributors
$ sudo pacman -S i3
[sudo] password for w: 
:: There are 4 members in group i3:
:: Repository extra
   1) i3-wm  2) i3blocks  3) i3lock  4) i3status

I don’t want to break anything or install a version of i3 that’s not compatible with the one I’m using! There’s a tool called " i3-resurrect" which may help me offset the need for this updated i3, but I wanted to check with you before doing anything. Thanks a bunch!

Version 4.8 is from 2014, so if that feature was added in 4.8, 4.22 will include it.

Version 4.22 is 14 versions newer than 4.8.

Right, apologies, I looked at the dot and was thinking in fractions.
Anyway, I solved the issue by digging more into the error message:

$ i3-save-tree --workspace=10 --output social.json
Can't locate AnyEvent/I3.pm in @INC (you may need to install the AnyEvent::I3 module) (@INC entries checked: /usr/lib/perl5/5.38/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.38/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.38/core_perl /usr/share/perl5/core_perl) at /usr/bin/i3-save-tree line 19.
BEGIN failed--compilation aborted at /usr/bin/i3-save-tree line 19.

Googling led to this site which proposed installing:


Installing the first package did it. Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.