[Solved] Unable to install drivers on laptop Nvidia GPU

Hi All.

I have an Dell Inspiron 5560 laptop and below are its inxi -xFz details. It has an Intel iGPU with Nvidia TU117GLM (T1200) laptop GPU.

  Kernel: 5.19.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: KDE Plasma v: 5.25.4 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Dell product: Precision 5560 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0WPMMN v: A00 serial: <superuser required> UEFI: Dell
    v: 1.10.1 date: 05/09/2022
  ID-1: BAT0 charge: 77.7 Wh (100.0%) condition: 77.7/84.3 Wh (92.2%)
    volts: 12.9 min: 11.4 model: SMP DELL 70N2F95 status: full
  Device-1: hidpp_battery_1 model: Logitech Wireless Mouse M510 charge: 55%
    (should be ignored) status: discharging
  Device-2: hidpp_battery_2 model: Logitech Wireless Keyboard K540/K545
    charge: 100% (should be ignored) status: discharging
  Info: 8-core model: 11th Gen Intel Core i7-11850H bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 640 KiB L2: 10 MiB L3: 24 MiB
  Speed (MHz): avg: 2500 min/max: 800/4800 cores: 1: 2500 2: 2500 3: 2500
    4: 2500 5: 2500 6: 2500 7: 2500 8: 2500 9: 2500 10: 2500 11: 2500 12: 2500
    13: 2500 14: 2500 15: 2500 16: 2500 bogomips: 79888
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-12.1 bus-ID: 00:02.0
  Device-2: NVIDIA TU117GLM [T1200 Laptop GPU] vendor: Dell driver: N/A
    arch: Turing bus-ID: 01:00.0
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-11:5
  Device-4: Logitech Logitech Webcam C925e type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 3-5.3.1:10
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    gpu: i915 resolution: 1: 3440x1440 2: N/A
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 3-5.3.1:10 bus-ID: 00:1f.3
  Device-2: Logitech Logitech Webcam C925e type: USB
    driver: snd-usb-audio,uvcvideo
  Device-3: Corsair VOID ELITE Wireless Gaming Dongle type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-5.3.3:12
  Sound Server-1: ALSA v: k5.19.5-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 2-3.4:5
  IF: enp0s13f0u3u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:7
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 1.82 TiB used: 131.3 GiB (7.0%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 2TB
    size: 1.82 TiB temp: 46.9 C
  ID-1: / size: 409.38 GiB used: 17.1 GiB (4.2%) fs: ext4 dev: /dev/dm-0
    mapped: luks-75283e00-bce1-4f99-a735-ac2d7218cc0c
  ID-2: /boot/efi size: 1.95 GiB used: 472 KiB (0.0%) fs: vfat
    dev: /dev/nvme0n1p6
  Alert: No swap data was found.
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 317 Uptime: 5m Memory: 31.08 GiB used: 2.24 GiB (7.2%)
  Init: systemd Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1089
  Shell: Bash v: 5.1.16 inxi: 3.3.20

No matter what I do, including following all the different ways to install the nvidia using nvidia-inst or nvidia-installer-dkms, all of them say they installed the nvidia driver successfully, still the driver refuses to be used. inxi -G shows the nvidia card is not using the driver. Any ideas on how to fix this? I ultimately want to use optimus-manager-qt to switch between the iGPU and dGPU

Could you please show the output of command

nvidia-driver-supported-branches -a

Here’s the output of nvidia-driver-supported-branches -a

NVIDIA card id: 1fbc
The nvidia-dkms version: 515.65.01-2
Series 515: supported (Nvidia: 515.65.01)
Series 515: supported (Nvidia: 515.43.04)
Series 470: supported (Nvidia: 470.141.03)
Series 390: not supported

More info: https://www.nvidia.com/en-us/drivers/unix

All of this worked fine until the GRUB issue screwed up my install and I had to reinstall :frowning:

What does pacman -Q | grep -E "nvidia|linux" show?

I don’t know if this applies here, but did you need to implement the “ibt=off” kernel parameter fix for nvidia / intel a month or two back? I’m wondering because if you had that in grub and now reinstalled without it, that could be a problem.

1 Like

Here’s the output

lib32-nvidia-utils 515.65.01-1
linux 5.19.5.arch1-1
linux-api-headers 5.18.15-1
linux-firmware 20220708.be7798e-1
linux-firmware-whence 20220708.be7798e-1
linux-headers 5.19.5.arch1-1
nvidia-dkms 515.65.01-2
nvidia-hook 1.0-1
nvidia-inst 1.2-1
nvidia-installer-common 1.3-1
nvidia-installer-db 2.5.8-1
nvidia-installer-dkms 3.5-1
nvidia-settings 515.65.01-1
nvidia-utils 515.65.01-2
util-linux 2.38.1-1
util-linux-libs 2.38.1-1

Don’t remember doing this, but will try it and keep you posted. Thanks for bringing this up

Have you rebooted?

Have you tried using the kernel parameter ibt=off and then update grub.

Thats it folks. The ibt=off parameter made all the difference. Once it was put in place, everything else worked perfectly. Thanks everyone for helping fix the issue.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.