[SOLVED]Two Questions About Acer Swift X Computer

Two days ago I obtained a new Acer Swift X SFX14-41G-R1S6 Creator Laptop | 14" Full HD 100% sRGB | AMD Ryzen 7 5800U | NVIDIA RTX 3050Ti Laptop GPU | 16GB LPDDR4X | 512GB NVMe SSD | Wi-Fi 6 | Backlit Keyboard | Windows 10 Home.

I immediately made the necessary changes in the UEFI/BIOS and installed EndeavourOS (and in the process completely removed Windows from the computer).

Using the latest installation ISO, the entire process went smoothly and I even was able to select the NVidia GPU. The time taken from installation, to rebooting, and to updating took about a half an hour.

Everything generally works correctly except for two things about which I have questions.

First - the Fn + F3, F4, and F5 keys, which control the brightness of the screen (F5 turns the screen on and off) do not work. Is there some program which will restore their functionality?

Second - this computer has no SysRq key. Is there a program by which I could assign this functionality to some key (for example, the PrtSc key)?

Thanks to anyone who will be able to answer one or both of these questions. By the way, this computer is a really nice one.

Lawrence

Wow. That sounds like a nice rig. Did you look at systemctl --failed and also look through sudo dmesg and see if there is any errors relating to the backlighting. On my HP i used this kernel parameter and i also disabled a service that shows up in dmesg related to amdgpu_b10

You could try the following kernel parameter also and see if it works. There are a number of these parameters for this and depends on manufacturer.

acpi_backlight=video

Edit: Don’t forget to run sudo grub-mkconfig -o /boot/grub/grub.cfg after adding the kernel parameter in the default grub command line.

Also here is the enable magic sysrq key

2 Likes

Dear ricklinux,

I know how to activate the SysRq key; it is active on all of my other computers.

But this computer does not have a SysRq key! The PrtSc key seems only to be for printing the screen and there is nothing else with the SysRq marking on it.

What to do?

Lawrence

Usually it is the PrtSc. Did you try that one?

Edit: It was in the instructions.

(if you can’t find it, typically, it shares the same physical key as the Print Screen key, but on some laptops it can be elsewhere

1 Like

Not sure on the laptop, but the fn keys may require kernel patches / dkms . Unless your not using a ‘de’ then you would need to bind them yourself, although I’m sure your aware of that :slight_smile:

1 Like

Dear ricklinux,

I sincerely apologize for not responding to you sooner but, right in the middle of our conversation, my wife called me to come to lunch (and one must always obey one’s wife - A Happy Wife is a Happy Life) and, after lunch, I was told that I had a lot of errands to run and some other chores in which to engage.

That said, this morning I “fired up” this Acer computer and tried the Print Screen key as you suggested. The “Magic SysRq” key function worked perfectly. I don’t know why I hadn’t tried that for myself before asking about it. I do find it odd that Acer would label this key only PrtSc and not have SysRq printed on it too. Thanks for your suggestion.

As for my other problem, I found the answer myself, also this morning. I went back into the BIOS and saw an option Function key behavior. I hadn’t noticed this before. The default was Media key. The other option was Function key. When I chose that option, the function keys worked perfectly.

I suppose that I should have experimented much further before bothering people here with my “problems” and, for that, I also apologize.

I do very much thank all who have responded to me and, especially, to ricklinux whose advice pointed me in the right direction.

Lawrence

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.