[SOLVED] - Touchpad not detected

Hello, I made a fresh install of EndeavourOS (KDE-flavored) but it seems my touchpad is simply not detected (this wasn’t the case in the installer either). Here’s a specific picture of what I’m getting. The laptop is a Lenovo Ideapad s145-15ii. If anyone knows what’s going on (or knows where to find information), I would be really happy. I can follow the arch wiki but I’m not sure if there’s any difference in EndeavourOS. Thank you!

In terms of functionality, ARCH wiki information will work - if you can successfully extract it! SOrry, don’t have a touchpad to test for you - but someone will probably be along. Might want to prepare a bit of info about your machine to post, like lspci, inxi -Fxxxza and so on…

@Saegusa7

Welcome to the forum. Thanks for giving EndeavourOS a try. I hope you enjoy your time here.

Pudge

Thanks Pudge and freebitrd54, I appreciate it. Here are more pictures depicting the issue. It seems X just doesn’t see the touchpad. I also checked the BIOS settings to make sure it wasn’t disabled, but I didn’t see anything. I have never installed Linux on this laptop so maybe this is a hardware issue. Anyway, here are the pics:


EDIT: It seems the issue might be drivers. It might be available in newer kernels but I’m not sure how to update the kernel itself.

Hello @Saegusa7
Could you try a kernel parameter to boot with and see if the touch pad shows up. You can add it to your default grub after"quiet"

sudo nano /etc/default/grub

Add the following and save.

i8042.nopnp=1 pci=nocrs 

Then update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then reboot and see if it shows up. If you aren’t sure on kernel parameters.

https://wiki.archlinux.org/index.php/Kernel_parameters#GRUB

1 Like

That solved the issue! For future reference, there’s also this: https://github.com/pavlepiramida/elan_i2c_dkms

Thank you very much!

1 Like

Looks like the other one builds a dkms module for the elantech touch pad? :thinking: Hadn’t seen that one.

Yeah apparently changing the parameters didn’t cut it for them.

So the parameters didn’t cause any other problem for you and the touch pad works properly?

So far looks good. The touchpad is working properly.

1 Like

@Saegusa7 Welcome and I am happy to see that you got it working.

The Elentech touch pads can be a pain to get working properly under Linux. They do not seem to “talk” to the kernel properly. It will spam the logs with errors and then stop working or not be recognized. It took me about 3 months to get mine (elan 1200) working. At the time, I did try the driver from that GitHub page and other “tweaks” without success. (BTW, it will only build on the 4.19 kernel) What ended up getting it to work for me was a kernel parameter. acpi_osi='Windows 2018' I still had to have a cron job setup to “reset” the driver every 5 minutes. Later, with newer kernels, I could get rid of the cron job, but the kernel parameter had to stay.

Even now, almost 2 years later on an Arch install, I still have to use the mentioned kernel parameter, or the touch pad will “do its own thing” and not work properly.

For informational pruposes: here is the mess I went through.

1 Like