[SOLVED] Thermald installed, next step

I installed thermald, and as per Endeavour Discovery on this page, I did the --needed bit, then tried to do sudo cp /usr/lib/systemd/system/thermald.service /etc/systemd/system/, but the terminal output is sudo cp /usr/lib/systemd/system/thermald.service /etc/systemd/system/.

What should be my next step?

Is this actually correct or did you just copy-paste the command you tried to run in the terminal? It does not make sense to me.

You are right, that is not the output, here it is:

cp: cannot stat '/usr/lib/systemd/thermald.service': No such file or directory

My apologies for the mix-up.

/usr/lib/systemd/thermald.service
There is no such a file.

It should be /user/lib/systemd/system/thermald.service

Perhaps you had a typo initially?

Check:
pacman -Ql thermald

man pacman

-Q, --query
Query the package database. This operation allows you to view installed packages and their files, as well as meta-information about individual packages (dependencies, conflicts, install date, build date, size). This can
be run against the local package database or can be used on individual package files. In the first case, if no package names are provided in the command line, all installed packages will be queried. Additionally, various
filters can be applied on the package list. See Query Options below.

-l, --list
List all files owned by a given package. Multiple packages can be specified on the command line.

As the message states - there is no file thermald.service so it cannot copy it.

Check if you already have the file in the /etc directory

ls /etc/systemd/system/thermald.service

If that does not return the name /etc/systemd/system/thermald.service then you cannot enable the service.

I would expect that during the installation of the package you it already copied the file into the /etc directory but it is better to check.

edit:

Good catch. I didn’t notice that it is missing system in the path.

1 Like

Correct, I missed the “system” bit.

So, it worked, got nano to open the file,
but the lineExecStart=/usr/bin/thermald --no-daemon --dbus-enable is not there.

Instead, there is ExecStart=/usr/bin/thermald --systemd --dbus-enable --adaptive.

The guide was written March 2021.
Perhaps thermald.service is shipped with a new ExecStart line now.

I am not seeing anything in ArchWiki related to changing that line https://wiki.archlinux.org/title/CPU_frequency_scaling#thermald

So I am afraid I am not sure what the “updated” course of action is now.

You could of course try the suggested line and see how it will work out.

I don’t have this package installed, but you might also want to have a look at

man thermald

to check what the command line options mean.

–ignore-cpuid-check
Ignore cpuid check for supported CPU models.

OK, I’ll try that. I’ll let you know.

1 Like

Thermald seems to have been changed, since when the wiki tutorial was written. This command is the relevant replacement to the one in the wiki.
If you want to modify some setting, I would suggest you only add some parameter, not change the existing command line.

Configuration can be applied using some xml files, as described in man thermald.
I would suggest you follow the recent man page and thermald devs latest info, instead of copy/pasting from old articles on the Web.
I suppose EnOS wiki will be updated, when possible, to reflect changes. @joekamprad ? :wink:

done that… was only the text in the screenshot it was already the new line…

To use thermald you need to remove or mask power-profiles-daemon also…

sudo systemctl mask power-profiles-daemon

1 Like

OK, everything is fine now. I will mark this issue as solved, all the comments here contributed to the solution. So, many thanks to @vlkon, @pebcak, @petsam and @joekamprad for your input.

I’m getting to know this OS slowly-slowly, piano-piano, siga-siga, but it is a great journey!

2 Likes

@Klaas-Vaak I randomly marked Joe’s post as solved, so the post will close to avoid necro bumping in the future. :wink:

Fair enough, you’re the boss.
In any case, congrats on creating this great forum, as well as excellent background info/wiki. :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.