[Solved] Question about ss -tlnup output in EndeavourOS

I am wondering why EndeavourOS, latest ISO, when running the ss command to see network ports with the -tlnup switches shows this:


And my Arch system shows this:

I tested this with firewalld enabled by default and then stopped the service. I did the same test in my own Arch install. I installed firewalld, nftables and iptables-nft in my own Arch install. I noticed the EndeavourOS ISO has the legacy iptables. I had tested my own Arch with the legacy iptables, but the results were the same. Any ideas?

I know there might be different services running, but I was surprised to see no output in EndeavourOS. When I ran the watch ss command and opened Firefox and browsed the web, I can see network port activity in EndeavourOS, but it is only udp port activity. I am curious why the vast difference in output.

That output basically shows you are running sshd, cupsd, systemd-resolved and systemd-network.

I would have to check to be sure but I don’t think the ISO has any of those running.

2 Likes

The live installer environment isn’t running services that are running in the installed system. :person_shrugging:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.