[Solved] Problems with Grub, after installation

Hello,

I install the system, I do not know if I did something wrong but I put /efi to the first fat32 partition and install the system in the P7, now when it boots the other systems do not appear in the entries, I go to the terminal:

[alnone@alnone-inspiron3583 ~]$ LANG=C sudo pacman -S os-prober
[sudo] password for alnone: 
warning: os-prober-1.81-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Package (1)      Old Version  New Version  Net Change

extra/os-prober  1.81-1       1.81-1         0.00 MiB

Total Installed Size:  0.06 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                        [--------------------------------------] 100%
(1/1) checking package integrity                                      [--------------------------------------] 100%
(1/1) loading package files                                           [--------------------------------------] 100%
(1/1) checking for file conflicts                                     [--------------------------------------] 100%
:: Processing package changes...
(1/1) reinstalling os-prober                                          [--------------------------------------] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Checking which packages need to be rebuilt
[alnone@alnone-inspiron3583 ~]$ nano /etc/default/grub
[alnone@alnone-inspiron3583 ~]$ LANG=C sudo grub-mkconfig -o /boot/grub/grub.cfg 
sudo: grub-mkconfig: command not found
[alnone@alnone-inspiron3583 ~]$ LANG=C update-grub
bash: update-grub: orden no encontrada
[alnone@alnone-inspiron3583 ~]$ sudo -i
[root@alnone-inspiron3583 ~]# grub-mkconfig -o /boot/grub/grub.cfg
-bash: grub-mkconfig: orden no encontrada
[root@alnone-inspiron3583 ~]# LANG=C grub-mkconfig -o /boot/grub/grub.cfg
-bash: grub-mkconfig: orden no encontrada
[root@alnone-inspiron3583 ~]# pacman -S update-grub
error: no se ha encontrado el paquete: update-grub
[root@alnone-inspiron3583 ~]# yay -S update-grub
 -> Evite ejecutar yay como root/sudo.
AUR Explicit (1): update-grub-0.0.1-8
Sync Dependency (1): grub-2:2.12-2
:: (1/1) PKGBUILD Descargado : update-grub
  1 update-grub                      (Archivos de compilaciĆ³n existen)
==> ĀæPaquetes a limpiar antes de compilar?
==> [N]inguno [A]Todos [Ab]ortar [I]nstalados [No]Instalados o (1 2 3, 1-3, ^4)
==> A
:: Borrando (1/1): /tmp/yay/update-grub
HEAD estĆ” ahora en d0b7d22 Update .SRCINFO (really sorry for the commit spam y'all, I haven't slept in two days)
  1 update-grub                      (Archivos de compilaciĆ³n existen)
==> ĀæDiffs a mostrar?
==> [N]inguno [A]Todos [Ab]ortar [I]nstalados [No]Instalados o (1 2 3, 1-3, ^4)
==> N
==> ERROR: Ejecutar makepkg como superusuario no estƔ permitido ya que puede causar daƱos
permanentes y catastrĆ³ficos a su sistema.
 -> error descargando fuentes: /tmp/yay/update-grub 
	 context: exit status 10 
	 

:: (1/1) Analizando SRCINFO: update-grub
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquete (1)  VersiĆ³n nueva  Diferencia neta  TamaƱo de la descarga

core/grub    2:2.12-2             33.67 MiB               6.84 MiB

TamaƱo total de la descarga:      6.84 MiB
TamaƱo total de la instalaciĆ³n:  33.67 MiB

:: ĀæContinuar con la instalaciĆ³n? [S/n] s
:: Obteniendo los paquetes...
 grub-2:2.12-2-x86_64                       6.8 MiB  4.51 MiB/s 00:02 [--------------------------------------] 100%
(1/1) comprobando las claves del depĆ³sito                             [--------------------------------------] 100%
(1/1) verificando la integridad de los paquetes                       [--------------------------------------] 100%
(1/1) cargando los archivos de los paquetes                           [--------------------------------------] 100%
(1/1) comprobando conflictos entre archivos                           [--------------------------------------] 100%
:: Procesando los cambios de los paquetes...
(1/1) instalando grub                                                 [--------------------------------------] 100%
:: Install your bootloader and generate configuration with:
     # grub-install ...
     # grub-mkconfig -o /boot/grub/grub.cfg
Dependencias opcionales para grub
    freetype2: For grub-mkfont usage [instalado]
    fuse3: For grub-mount usage [instalado]
    dosfstools: For grub-mkrescue FAT FS and EFI support [instalado]
    lzop: For grub-mkrescue LZO support
    efibootmgr: For grub-install EFI support [instalado]
    libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue
    os-prober: To detect other OSes when generating grub.cfg in BIOS systems [instalado]
    mtools: For grub-mkrescue FAT FS support [instalado]
:: Ejecutando los Ā«hooksĀ» de posinstalaciĆ³n...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating the info directory file...
==> ERROR: Ejecutar makepkg como superusuario no estƔ permitido ya que puede causar daƱos
permanentes y catastrĆ³ficos a su sistema.
 -> error compilando: update-grub-exit status 10
 -> Ha fallado al instalar los siguientes paquetes. Una intervenciĆ³n manual es requerida:
update-grub - exit status 10
[root@alnone-inspiron3583 ~]# pacman -S os-prober
advertencia: os-prober-1.81-1 estƔ actualizado -- reinstalƔndolo
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquete (1)      VersiĆ³n antigua  VersiĆ³n nueva  Diferencia neta

extra/os-prober  1.81-1           1.81-1                0.00 MiB

TamaƱo total de la instalaciĆ³n:  0.06 MiB
TamaƱo neto tras actualizar:     0.00 MiB

:: ĀæContinuar con la instalaciĆ³n? [S/n] s
(1/1) comprobando las claves del depĆ³sito                             [--------------------------------------] 100%
(1/1) verificando la integridad de los paquetes                       [--------------------------------------] 100%
(1/1) cargando los archivos de los paquetes                           [--------------------------------------] 100%
(1/1) comprobando conflictos entre archivos                           [--------------------------------------] 100%
:: Procesando los cambios de los paquetes...
(1/1) reinstalando os-prober                                          [--------------------------------------] 100%
:: Ejecutando los Ā«hooksĀ» de posinstalaciĆ³n...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Checking which packages need to be rebuilt
[root@alnone-inspiron3583 ~]# grub-mkconfig -o /boot/grub/grub.cfg
/usr/bin/grub-mkconfig: lĆ­nea 270: /boot/grub/grub.cfg.new: No existe el fichero o el directorio
[root@alnone-inspiron3583 ~]# LANG=C grub-mkconfig -o /boot/grub/grub.cfg
/usr/bin/grub-mkconfig: line 270: /boot/grub/grub.cfg.new: No such file or directory
[root@alnone-inspiron3583 ~]# update-grub
-bash: update-grub: orden no encontrada
[root@alnone-inspiron3583 ~]# LANG=C update-grub
-bash: update-grub: orden no encontrada
[root@alnone-inspiron3583 ~]#

There is nothing after/in #nano /etc/default/grub

i believe you need to edit grub,cfg and uncomment the line for OS prober.

that should be in
/boot not /etc

Post:

pacman -Q grub

sudo parted -l

efibootmgr

cat /etc/fstab

cat /etc/default/grub
[alnone@alnone-inspiron3583 ~]$ pacman -Q grub
grub 2:2.12-2
[alnone@alnone-inspiron3583 ~]$ LANG=C sudo parted -l
[sudo] password for alnone: 
Model: PC SN520 NVMe WDC 256GB (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  1537MB  1536MB  fat32                 boot, esp
 2      1537MB  3064MB  1527MB  linux-swap(v1)        swap
 3      3064MB  45.6GB  42.5GB  ext4
 4      45.6GB  94.4GB  48.8GB  ext4
 5      94.4GB  146GB   52.1GB  btrfs
 6      146GB   210GB   63.6GB  ext4
 7      210GB   256GB   46.0GB  ext4


[alnone@alnone-inspiron3583 ~]$ LANG=C efibootmgr
BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0004,0002,0006,0001,0000,0003
Boot0000* MX21	HD(1,GPT,1f8b0ce7-b5a4-4236-8019-565e23b47888,0x800,0x2dc800)/\EFI\MX21\grubx64.efi
Boot0001* MX23	HD(1,GPT,1f8b0ce7-b5a4-4236-8019-565e23b47888,0x800,0x2dc800)/\EFI\MX23\grubx64.efi
Boot0002* garuda	HD(1,GPT,1f8b0ce7-b5a4-4236-8019-565e23b47888,0x800,0x2dc800)/\EFI\garuda\grubx64.efi
Boot0003* UEFI: PC SN520 NVMe WDC 256GB, Partition 1	HD(1,GPT,1f8b0ce7-b5a4-4236-8019-565e23b47888,0x800,0x2dc800)/\EFI\boot\bootx64.efi0000424f
Boot0004* Linux Boot Manager	HD(1,GPT,1f8b0ce7-b5a4-4236-8019-565e23b47888,0x800,0x2dc800)/\EFI\systemd\systemd-bootx64.efi
Boot0006* ubuntu	HD(1,GPT,1f8b0ce7-b5a4-4236-8019-565e23b47888,0x800,0x2dc800)/\EFI\ubuntu\shimx64.efi
[alnone@alnone-inspiron3583 ~]$ LANG=C cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=6693-9A38                            /efi           vfat    fmask=0137,dmask=0027 0 2
UUID=61f4557b-6f8d-4ba4-b130-3e852a6e69e5 /              ext4    noatime    0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
[alnone@alnone-inspiron3583 ~]$ LANG=C cat /etc/default/grub
# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.
#GRUB_DISABLE_OS_PROBER=false
[alnone@alnone-inspiron3583 ~]$

nothing after /boot/default/grub empty

Iā€™m not sure where grub stores its config file anymore its been a while since I have used it was basically going off memory.

@pebcak can give you much clearer info to get you back up and running so I will leave you in his very capable hands.

1 Like

thanks

You seem that you have done a default installation of EnOSā€™ .

The default bootloader for EnOS is systemd-boot and not grub and the default mountpoint for ESP with systemd-boot is /efi and not /boot/efi.

This can be seen:

Boot0004* Linux Boot Manager	HD(1,GPT,1f8b0ce7-b5a4-4236-8019-565e23b47888,0x800,0x2dc800)/\EFI\systemd\systemd-bootx64.efi
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=6693-9A38                            /efi           vfat    fmask=0137,dmask=0027 0 2

This why you are having problem with grub. Grub is simply non-functional and unneeded on your system.

If you want to let your EnOSā€™ systemd-boot manage booting of your other Linux systems (which use grub), read carefully through the following article to get acquainted with systemd-boot:

https://wiki.archlinux.org/title/Systemd-boot

Specially this part to create boot entry for your other systems:

https://wiki.archlinux.org/title/Systemd-boot#GRUB

1 Like

Are you sure you were using grub and not systemd-boot?

I see, well that is to difficult for my level, i think it is better to reinstall, now how do we do that right in Calamares?, the options were /efi, in Fat32 (without to format, of course) would you tell me what i did wrong in Calamares? thanks.

during the install process you choose the boot loader. Systemd is the default but you can switch it to grub if you prefer to use grub as many other users here do.

Are all those systems as shown in the output of the efibootmgr installed and functional?

MX21, MX23, Garuda and Ubuntu?

Yes, all thse systems work perfectly.

during the install process you choose the boot loader.

during the installation I didnā€™t see at any time that I could take for that option, maybe that was my problem. I will try again ā€¦

been a minute since iā€™ve done an install so I donā€™t remember where it comes up at but iā€™m sure its around the partition part of the installer

Was this a response to my question?

If so, from now on use the reply button under the post you want to reply to for the person in question to get notified.

So, for example, if your MX23 is installed and functional, do the following to create a boot entry for it:

sudo nano /efi/loader/entries/mx23.conf

and put the following in:

title MX Linux 23
efi /EFI/MX23/grubx64.efi

save the file.

Reboot and check if you have a boot entry for MX Linux 23 on your EnOSā€™ systemd-boot menu.

Try booting it up and see if it will take you to MX23 grub boot menu.

If this works. Do the same for all the other systems. Check the output of the efibootmgr to see what efi binary and what location you need to use in each case.

Sorry for the bad post ā€¦

While you was be writing the post I decided to reinstall, well, the thing was that I did the installation in a hurry, did not consider the options and continued ā€¦ and it was left with (systemd/boot) that comes by default (bad idea).

Now after uncommenting os-prober ā€¦ and sudo grub-mkconfig -o /boot/grub/grub.cfg everything is in order.

Thank you all very much for the instructions.

1 Like

No problem!

Glad that you could set up your system the way you want it to be!

As always, the rush ā€¦

Do not recognize Garuda,

type or paste calnone@alnone-inspiron3583 ~]$ sudo -i
[sudo] contraseƱa para alnone: 
[root@alnone-inspiron3583 ~]# os-prober
/dev/nvme0n1p3:MX 21.3 Wildflower (21.3):MX:linux
/dev/nvme0n1p4:MX 23.2 Libretto (23.2):MX1:linux
/dev/nvme0n1p6:Linux Mint 21.3 Virginia (21.3):LinuxMint:linux
[root@alnone-inspiron3583 ~]# 

ode here
[root@alnone-inspiron3583 ~]# LANG=C sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found background: /usr/share/endeavouros/splash.png
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found MX 21.3 Wildflower (21.3) on /dev/nvme0n1p3
Found MX 23.2 Libretto (23.2) on /dev/nvme0n1p4
Found Linux Mint 21.3 Virginia (21.3) on /dev/nvme0n1p6
Adding boot menu entry for UEFI Firmware Settings ...
done
[root@alnone-inspiron3583 ~]# 


Is this Garuda?

Unfortunately the edition of os-prober in Arch repo doesnā€™t recognize other systems on the disk installed on Btrfs.

You could either bring up your BIOSā€™ boot menu to boot up Garuda.

Or you would need a patched version of os-prober like the one from Manjaro. See:

Another option would still be to use systemd-boot but not as bootloader but as boot manager to mange the grub of your other systems.

Thanks!

1 Like