[SOLVED] `pandoc` needs `lmodern.sty` file, however I can't install it with `pacman`

What happened?

pandoc fails:

$ pandoc file.md -o file.pdf
Error producing PDF.
! LaTeX Error: File `lmodern.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name: 
! Emergency stop.
<read *> 
l.19 \ifPDFTeX

What have I tried?

The error is clear: lmodern.sty is missing. I tried to find it:

$ pacman -F lmodern.sty
extra/texlive-core 2023.66594-7 (texlive)
$ pacman -Si texlive-core
error: package 'extra/texlive-core' was not found
# However, it is provided by texlive-basic
$ pacman -Ss texlive-core
extra/texlive-basic 2023.66594-14 (texlive) [installed]
    TeX Live - Essential programs and files
$ pacman -Ql texlive-basic | grep lmodern.sty
# couldn't find it tho

How can I find lmodern.sty and make pandoc work again?

My system info

  • inxi -Fxz
  Kernel: 6.3.9-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    Desktop: i3 v: 4.22 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 82MF v: IdeaPad 3 15ALC6
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    UEFI: LENOVO v: GLCN46WW date: 04/29/2022
  ID-1: BAT0 charge: 19.7 Wh (58.3%) condition: 33.8/38.0 Wh (88.9%)
    volts: 7.7 min: 7.7 model: SMP L20M2PF0 status: discharging
  Info: 6-core model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 2 rev: 1 cache: L1: 384 KiB L2: 3 MiB L3: 8 MiB
  Speed (MHz): avg: 1532 high: 2100 min/max: 1400/4056 boost: enabled cores:
    1: 1397 2: 1397 3: 1397 4: 1400 5: 1400 6: 1604 7: 1399 8: 1400 9: 1399
    10: 2100 11: 1400 12: 2100 bogomips: 50322
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Lucienne vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5
    bus-ID: 03:00.0 temp: 40.0 C
  Device-2: Chicony Integrated Camera driver: uvcvideo type: USB
    bus-ID: 1-3:2
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: amdgpu
    unloaded: modesetting dri: radeonsi gpu: amdgpu resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 23.1.2 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.52 6.3.9-arch1-1) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 03:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    bus-ID: 03:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 03:00.6
  API: ALSA v: k6.3.9-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.71 status: active
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw_8822ce v: N/A port: 2000 bus-ID: 01:00.0
  IF: wlan0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB
    bus-ID: 3-4:2
  Report: rfkill ID: hci0 rfk-id: 5 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 238.47 GiB used: 60.1 GiB (25.2%)
  ID-1: /dev/nvme0n1 vendor: SSSTC model: CL1-4D256 size: 238.47 GiB
    temp: 29.9 C
  ID-1: / size: 232.7 GiB used: 60.03 GiB (25.8%) fs: ext4 dev: /dev/nvme0n1p2
  Alert: No swap data was found.
  System Temperatures: cpu: 43.6 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (RPM): N/A
  Processes: 268 Uptime: 1h 49m Memory: available: 5.65 GiB
  used: 2.72 GiB (48.1%) Init: systemd Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: 1093 Shell: Bash v: 5.1.16 inxi: 3.3.27
  • pacman -Qi texlive-basic pandoc-bin
Name            : texlive-basic
Version         : 2023.66594-14
Description     : TeX Live - Essential programs and files
Architecture    : any
URL             : http://tug.org/texlive/
Licenses        : GPL
Groups          : texlive
Provides        : texlive-core  texlive-amsfonts  texlive-bibtex  texlive-cm  texlive-colorprofiles  texlive-dvipdfmx  texlive-dvips  texlive-ec  texlive-enctex  texlive-etex  texlive-etex-pkg  texlive-glyphlist  texlive-graphics-def  texlive-hyph-utf8  texlive-hyphen-base  texlive-hyphenex  texlive-ifplatform  texlive-iftex  texlive-knuth-lib  texlive-knuth-local  texlive-kpathsea  texlive-lua-alt-getopt  texlive-luahbtex  texlive-luatex  texlive-makeindex  texlive-metafont  texlive-mflogo  texlive-mfware  texlive-modes  texlive-pdftex  texlive-plain  texlive-tex  texlive-tex-ini-files  texlive-texlive-common  texlive-texlive-en  texlive-texlive-msg-translations  texlive-texlive-scripts  texlive-texlive.infra  texlive-tlshell  texlive-unicode-data  texlive-xdvi
Depends On      : texlive-bin
Optional Deps   : None
Required By     : texlive-latex  texlive-pictures
Optional For    : pandoc-bin
Conflicts With  : texlive-core
Replaces        : texlive-core
Installed Size  : 15,63 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : ter 20 jun 2023 06:25:49
Install Date    : sex 23 jun 2023 00:00:01
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Name            : pandoc-bin
Version         : 3.1.3-1
Description     : Pandoc - executable only, without 750MB Haskell depends/makedepends
Architecture    : x86_64
URL             : https://pandoc.org
Licenses        : GPL2
Groups          : None
Provides        : pandoc=3.1.3
Depends On      : None
Optional Deps   : texlive-core: for pdf output [installed]
Required By     : None
Optional For    : eos-apps-info
Conflicts With  : pandoc  pandoc-cli
Replaces        : None
Installed Size  : 131,34 MiB
Packager        : Unknown Packager
Build Date      : qui 15 jun 2023 11:36:03
Install Date    : qui 15 jun 2023 11:39:55
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None

You could try installing the package texlive-fontsrecommended, as that provides lmodern.sty.


Of course, I forgot to run sudo pacman -Fy before searching for lmodern.sty. Now it works good. Thanks!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.