(SOLVED)Pamac is not showing Packages to install

Hello to everybody in this forum

Im a new user on Endeavouros and im facing a problem with Pamac which is not showing any packages that i can install(Actually it shows a few ). it only shows the installed ones, the orphan ones and packages from the AUR repo.

By giving pacman -Q | grep pamac

libpamac-aur 11.2.0-5
pamac-aur 10.3.0-4

I have already updated my system and pamac database but the problem remains

how can i fix this





1 Like

What other packages are you expecting to see?

thanks for your reply

i cant see the packages too install most categories are empty while the category of games has three entries take a look at the screenshot i uploaded at the button of my post

What does

pacman -Qi archlinux-appstream-data


[babis@babis-George ~]$ pacman -Qi archlinux-appstream-data
Όνομα : archlinux-appstream-data
Έκδοση : 20220107-1
Περιγραφή : Arch Linux application database for AppStream-based software centers
Αρχιτεκτονική : any
URL : https://www.archlinux.org
Άδειες : GPL
Ομάδες : Ουδέν
Παρέχει : Ουδέν
Εξαρτάται από : Ουδέν
Προαιρετικές εξαρτήσεις : Ουδέν
Απαιτείται από : libpamac-aur pamac-aur
Προαιρετική εξάρτηση σε : Ουδέν
Διένεξη με : Ουδέν
Αντικαθιστά : Ουδέν
Μέγεθος εγκατάστασης : 20,03 MiB
Υπεύθυνος πακέτου : Antonio Rojas arojas@archlinux.org
Ημερομηνία δημιουργίας : Παρ 07 Ιαν 2022 10:21:48 μμ EET
Ημερομηνία εγκατάστασης : Τετ 02 Φεβ 2022 10:18:34 πμ EET
Αιτία εγκατάστασης : Εγκατεστημένο ως εξάρτηση άλλου πακέτου
Σενάριο εντολών εγκατάστασης : Όχι
Επικυρωμένο από : Υπογραφή

[babis@babis-George ~


Do it like this

LANG=C pacman -Qi archlinux-appstream-data


Is this a console command?


this is what i get:

Name : archlinux-appstream-data
Version : 20220107-1
Description : Arch Linux application database for AppStream-based software centers
Architecture : any
URL : https://www.archlinux.org
Licenses : GPL
Groups : None
Provides : None
Depends On : None
Optional Deps : None
Required By : libpamac-aur pamac-aur
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 20,03 MiB
Packager : Antonio Rojas arojas@archlinux.org
Build Date :
Install Date :
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

I see that there is this package archlinux-appstream-data-pamac in AUR with the description:

Arch Linux application database for AppStream-based software centers (Fixed for pamac-aur and pamac-all packages)

I wonder if that is the one you need to have. You might want to wait for other forum members more experienced with Pamac to comment on this.

If you go ahead and install that, it will conflict with the one you have already. When prompted, you need to say yes to remove it.


Thank you very much for your help on solving the issue with Pamac
Problem is solved!!! :grinning: :smiley: :smiley:

1 Like

Great to hear!

Please mark the post that pointed you to the solution by clicking … and checking the box. This will help others with similar issue to find the solution easier.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.