SOLVED - Pacman: failed to commit transaction eos-hooks

Hi all,
I’ve been updating regularly (every day) and on the latest update today (sudo pacman -Syu), which included kde 5.21.1, everything downloaded normally but on its checking for file conflicts, I got this error which stopped the update:

error: failed to commit transaction (conflicting files)
eos-hooks: /usr/share/libalpm/hooks/lsb-release.hook exists in filesystem
Errors occurred, no packages were upgraded.

Thanks for any help!

What is the output of:

pacman -Qo /usr/share/libalpm/hooks/lsb-release.hook
3 Likes

error: No package owns /usr/share/libalpm/hooks/lsb-release.hook

1 Like

You can overwrite it:

sudo pacman -S eos-hooks --overwrite=usr/share/libalpm/hooks/lsb-release.hook
5 Likes

Thanks a million dalto for the super-quick answer!

I’ll do it and report back.

2 Likes

It worked perfectly, thank you again.

Any idea why this happened? (I never mess with system files)

I am not sure why it happened. It wasn’t owned by a package so either something generated it and didn’t remove it or it was put there in another way.

I don’t think it will be a recurring issue.

1 Like

Cheers dalto

I studied this a bit with my older installs, and the file (/usr/share/libalpm/hooks/lsb-release.hook) looks like being some leftover from the install with the 2019-Sep-15 ISO. At that time we didn’t have the eos-hooks package, so it must have been directly copied there as a file by the installer.

And now we moved the EndeavourOS hook files into /usr/share/libalpm/hooks, which is a better place for them.

The purpose of the old and new files are the same.

2 Likes

I noticed the move of all the hooks - the /etc/pacman.d/hooks directory looks almost empty now by comparison! Mostly just my own plus a couple I borrowed…