[Solved]Ntsf mount problems

I’ve a strange behavior with mounting ntsf in fstab

mount -t ntsf-3g /dev/sda3 /mnt/sda3 ==> works

cd /mnt
mount -t ntsf-3g /dev/sda3 ./sda3 ==> doesn’t works (Missing modul ntsf-3g)
mount -t auto /dev/sda3 /mnt/sda3 ==> works == Filetype in /etc/mtab = “fuseblk”

UUID=“WINUID” ntsf-3g /mnt/sda3 ntsf-3g defaults,relatime 0 0 ==> doesn’t work (Missing modul ntsf-3g)
UUID=“WINUID” ntsf /mnt/sda3 ntsf-3g defaults,relatime 0 0 ==> doesn’t work at all

The only way to have the mounts online with start, is a combination with:
fstab ==> UUID=“WINUID” ntsf-3g /mnt/sda3 ntsf-3g **noauto,**relatime 0 0
and a cronjob
@reboot root { mount -t ntsf-3g /dev/sda3 /mnt/sda3 }

How can I make it smart working in fstab?


Welcome to EndeavourOS!

Seems to be a typo, the file system should be ntfs, not ntsf.

And you may shorten the type to ntfs also in fstab file instead of ntfs-3g.

(Hope I didn’t make the same typos… :wink: )

Thank you Manuel,
but the wrong typo was not the fstab error, because I don’t copy and past from fstab. It was only a typo error here in the forum - I used to make the same change typo error often… sorry.
All combinations of type=ntfs don’t work at all
uname -a: Linux Alberich 5.3.7-arch1-1-ARCH #1 SMP PREEMPT Fri Oct 18 00:17:03 UTC 2019 x86_64 GNU/Linux
It seems like that the actual kernel is not able to handle ntsf.
I try actually testing with the LTS kernel, but this one is not proper configured yet ( I forgott the header files :frowning: ) and there it was possible to mount with just ntfs.
I proceed with testing - stay tuned :wink:

I have nfts mounts in fstab and they work fine. So basically ntfs works. There may (must) be other settings that cause the trouble.

Just to be on the safe side, do you have package ntfs-3g installed?

Sorry Manuel, it works now.
It was a my fault - misconfiguration on more than one place.
After carefully reading of the fstab I found two stupid errors ( yes you were right - one ntsf was also there (shame on me))
Thanks a lot for your efforts
we can mark this as solved.

1 Like

BTW, who configurated the output on some lines from journalctl -xb the colours “darkblue on black” FUUUUU

Hi Thomas,
What terminal console do you use? There may be preferences/settings for different color combinations. I use KDE/Plasma/Konsole and there are several pre-built color combinations via easily modified profiles. Konsole > Settings > Profiles > New or Edit > Appearance > Color scheme & font. You can even create your own color scheme.

Hi CMarch,
it was the zsh Shell itself - because of the start rescue system. I’ve to find out whether I can manipulate this