[SOLVED] Mintstick problem

Does anyone have had problems with Mintstick lately? For example, if I try to format usb stick it gives this kind of error: “and error occured”. If I start it in terminal the output seems normal. No errors.The version I’m using is 1.4.4-1. I also tried the git version, but the result was same. The same problem occurs in two different laptops with Endeavour installs. But I noticed it works normally on my Manjaro and Arco Linux installs. Weird, huh? Could it be some updates I got recently? It worked perfectly before.

Why do you use a such tool? For writing images you should use dd.

For example, if you have written a 1 GiB image to a 3.73 GiB stick, you can’t just format it afterwards.

Write e.g. with gparted a new MBR on the stick, create a new partition and format it!

1 Like

Why do I use such a tool? Because it’s simple and has worked well. I know how to use gparted for formatting usb devices and dd is familiar to me also. But I didn’t ask alternative tools for such tasks. I wanted to know why mintstick stopped working that’s all.

1 Like

I don’t know about arco Linux, but depending on your Manjaro branch, you may still be running older stuff on it and the update hasn’t broken it there. I’ve never used mintstick. Gparted and popsicle work for me.

It’s not flagged out of date on the AUR, you may be the first to notice it’s broken. Please flag it so the maintainer can look into it.

I was just thinking the same thing.

Some people like a GUI is all. I find popsicle to be very reliable and minimalist as far as a GUI is concerned.

2 Likes

I’m not concerned with necessarily not using a graphical front end. However, many of these flashers work incorrectly or change the result and/or are unnecessarily bloated.

1 Like

There are some other advantages to it - you are not likely to misdirect its output, for one thing. It only shows removables as possible destinations. For another, it appears to be faster (no idea how or why) than dd (which is the only alternative for me) - I get EnOS ISO written in a couple of minutes - whereas a smoke break isn’t long enough for dd. Not to mention that the progress option doesn’t appear to continue through a dd write - mintstick shows progress properly. We’re not talking a huge GUI here either - it is not Balena Etcher! :grin:

Oh - you might have guessed I use it :smile_cat:

2 Likes

You really hit the right spot! It is fast and simple tool. I usually have few usb sticks specifically for writing linux isos on them. But sometimes if I need quickly format them for other use I use mintstick.
Popsicle is good tool also and I’m going to use it until I find solution for this mintstick problem.

Why is Balena Etcher so big? Is it because they have so much spyware in it?

It’s 100MB for something that usually takes a few MB.

When I get home I have to check if that Manjaro package really is different than the one is installed on EOS. If I recall the version number looked the same. But maybe it’s because of some dependencies…

With dd you should use a higher value with the bs option, also sync, e.g.:

# dd if=example.iso of=/dev/sdX bs=10M && sync

You can generate a progress bar in another way, it’s not quite as easy with an option. You don’t necessarily need it if you use the anyway recommendable sync.

Personally, I don’t usually use dd command. I’m the type who ends up asking for help in a thread after I dd my /sda . . . so.

Gparted works nicely still though. It’s been the standard forever.

If you’re looking to flash a USB to something, I’ve been rocking popsicle for quite some time now with great success and simplicity.

It could be. Again, if you haven’t updated Manjaro in a while, and you did just update EOS, your EOS will absolutely be more up to date than Manjaro. They aren’t as rolling as we are here.

That doesn’t mean that anything is different though. Everything could be identical. BUT, I would find it odd unless you’re missing something now. But I would guess something updated, either mintstick or one of it’s dependanceies causing the issue.

1 Like

It is based on electron. If you like, it is a “chromium for flashing”.

1 Like

I just used mintstick to create a EOS i3, no issues here.

Then it’s me only who has that problem… :anguished:
Probably some update hasn’t gone the way it should have. Missing packages etc…

How do they change the result?

Switch to popsicle-git :slightly_smiling_face:

git is the “newest”/latest" version correct?

So I just downloaded it and gave it a go. I also had no problem burning an iso.

[derek@archcinnamon ~]$ pacman -Qi mintstick
Name            : mintstick
Version         : 1.4.4-1
Description     : A GUI to write .img or .iso files to a USB Key. It can also format them
Architecture    : any
URL             : http://packages.linuxmint.com/pool/main/m/mintstick
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : coreutils  desktop-file-utils  dosfstools  e2fsprogs  exfat-utils
                  glib2  gtk3  ntfs-3g  parted  polkit  procps-ng  python  python-dbus
                  python-gobject  python-pyparted  python-xapp  udisks2  util-linux
                  xapps
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : mintstick-git
Replaces        : None
Installed Size  : 113.35 KiB
Packager        : Pedro Henrique Lara Campos <root@pedrohlc.com>
Build Date      : Wed 02 Dec 2020 07:35:15 AM PST
Install Date    : Wed 16 Dec 2020 08:36:19 AM PST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

[derek@archcinnamon ~]$ 

Please make sure you’re completely up to date yay and that you have all of my same packages/dependencies installed.

If all packages can’t be updated, please clear your cache and update again pacman -Sc followed by pacman -Syyu

If that is still unsuccessful, please cleanbuild the package again from the AUR.

1 Like