[solved] Lightdm stops working after update yesterday

I have some systems running “testing” and some “stable”. About 14 days ago I was hit by an issue regarding login with lightdm at my “testing”-based systems: I can select user, I can apply password, but after hitting “ENTER” (or clicking on login button) nothing happens. I have made a workaround by using sddm instead of lightdm - that fixed the issue. Today this issue has arrived “stable”. I can no longer login into system using lightdm…

For those who are impacted by this too here my solution:

Change symbolic link /etc/systemd/system/display-manager.service
from /usr/lib/systemd/system/lightdm-plymouth.service
to /usr/lib/systemd/system/sddm-plymouth.service

It doesn’t matter if the “-plymouth” is in use or not - the issue exists with lightdm itself.


You should use systemctl to manage that instead of doing it manually. Depending on if you have the plymouth version installed or not.

sudo systemctl enable sddm-plymouth.service -f


sudo systemctl enable sddm.service -f

As a side note, have you looked into why lightdm isn’t working instead of switching to sddm?

Yes, I tried to understand but I cannot identify the problem. There is absolutely nothing in the logs that points to an issue - but it is there and it is reproduceable (in the meantime on all 11 systems I own). And of course you are right in the way to fix it using my workaround! I know it is only a workaround but I cannot solve it otherway.

I have investigated a bit and found the following:
The issue only exists if lightdm-webkit2-greeter is used. I set debug=true in lightdm-webkit2-greeter.conf and now I can see the following in the logs:

Sep 25 09:33:30 arch-c2l systemd[1]: Starting Light Display Manager...
Sep 25 09:33:30 arch-c2l systemd[1]: Started Light Display Manager.
Sep 25 09:33:32 arch-c2l lightdm[961]: pam_unix(lightdm-greeter:session): session opened for user lightdm(uid=620) by (uid=0)
Sep 25 09:33:34 arch-c2l lightdm[1136]: pam_systemd_home(lightdm:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Sep 25 09:34:37 arch-c2l lightdm[1136]: gkr-pam: unable to locate daemon control file
Sep 25 09:34:37 arch-c2l lightdm[1136]: gkr-pam: stashed password to try later in open session
Sep 25 09:34:38 arch-c2l lightdm[1136]: pam_unix(lightdm:session): session opened for user andreas(uid=1000) by (uid=0)
Sep 25 09:34:38 arch-c2l lightdm[1136]: pam_env(lightdm:session): deprecated reading of user environment enabled
Sep 25 09:34:38 arch-c2l lightdm[1136]: gkr-pam: unlocked login keyring

At the moment I do not know how to investigate more. Webkit2-greeter seems to be pretty old: it uses “antergos” theme. And webkit2 was updatet during the last days. Maybe the issue is related to lightdm-webkit2-greeter package.

The webkit2 greeter is long abandoned. It hasn’t had a commit in over 4 years.

It doesn’t seem like anyone else opened any bugs on Arch about it being broken. I am not sure if that is because it isn’t widely used or if your issue isn’t related to that package.

I can spin up a VM in a little while and test it for you.

It would be interesting if you can reproduce the issue. I have had used the combination lightdm/webkit2-greeter on all of my machines.

Yes, I can reproduce it.

I spent a bit of time looking at it. Narrowing down the packages upgraded and doing a little testing it is probably related either to the recent glib2 upgrade or the recent libwpe upgrade.

If you can reproduce it on Arch, you might consider filing a bug against the Arch package.


Thank you - I will check it out.

The issue is located in the webkit2gtk package. At this moment a downgrade to 2.36.7-1 solves the issue. Thanks for helping to identify this!


I’m having the exact same issue. Currently staring at a console deciphering how to switch to startX. I’ve been using webkit2-greeter for a while because I prefer the look better than slick-greeter.

I’m going to try switching the greeter back to slick-greeter. Should solve issue given the above. Still thinking of trying simpler login via xinit and startX.

Thanks guys for figuring this out!! :sunglasses::v::muscle:

1 Like

Note to self:
The name of a thing in a config file is often NOT the same as the file name.





when used in lightdm.conf

What’s a few extra console logins and reboots, eh? :man_facepalming::man_facepalming::man_facepalming::rofl::rofl::rofl:

Simply downgrading webkit2gtk to 2.36.7-1 would do the job with webkitgreeter. I already have made a bug report on Arch bugs. It is not a problem of EndeavourOS - it is “upstream” :grin: