[SOLVED] KDE weird happenings after update

This post is a just in case anyone else is having odd things happen or know whats going on and possibly help.
I’ll try to be brief.

So last week I update 2 KDE machines.
Reboot machine 1, and conky doesn’t work.
Reboot machine 2, and desktop icons are gone, only welcome menu showing.
I downgrade back to the 7th everything working fine both machines.

Today machine 1, I decided I could live without conky and wait for an update.
I update, reboot and conky doesn’t work as expected.

Soon after that this morning, this update comes in and I update.

attica 5.90.0-1 -> 5.91.0-1
baloo 5.90.0-1 -> 5.91.0-1
binutils 2.36.1-3 -> 2.38-3
bluez-qt 5.90.0-1 -> 5.91.0-1
breeze-icons 5.90.0-1 -> 5.91.0-1
elfutils 0.186-4 -> 0.186-5
frameworkintegration 5.90.0-2 -> 5.91.0-1
gcc 11.1.0-3 -> 11.2.0-3
gcc-libs 11.1.0-3 -> 11.2.0-3
glibc 2.33-5 -> 2.35-2
kactivities 5.90.0-1 -> 5.91.0-1
kactivities-stats 5.90.0-1 -> 5.91.0-1
karchive 5.90.0-1 -> 5.91.0-1
kauth 5.90.0-1 -> 5.91.0-1
kbookmarks 5.90.0-1 -> 5.91.0-1
kcalendarcore 5.90.0-1 -> 5.91.0-1
kcmutils 5.90.0-1 -> 5.91.0-1
kcodecs 5.90.0-1 -> 5.91.0-1
kcompletion 5.90.0-1 -> 5.91.0-1
kconfig 5.90.0-1 -> 5.91.0-1
kconfigwidgets 5.90.1-1 -> 5.91.0-1
kcontacts 1:5.90.0-1 -> 1:5.91.0-1
kcoreaddons 5.90.0-1 -> 5.91.0-1
kcrash 5.90.0-1 -> 5.91.0-1
kdbusaddons 5.90.0-1 -> 5.91.0-1
kdeclarative 5.90.0-1 -> 5.91.0-1
kded 5.90.0-1 -> 5.91.0-1
kdelibs4support 5.90.0-1 -> 5.91.0-1
kdesu 5.90.0-1 -> 5.91.0-1
kdnssd 5.90.0-1 -> 5.91.0-1
kdoctools 5.90.0-1 -> 5.91.0-1
kemoticons 5.90.0-1 -> 5.91.0-1
kfilemetadata 5.90.0-1 -> 5.91.0-1
kglobalaccel 5.90.0-1 -> 5.91.0-1
kguiaddons 5.90.0-1 -> 5.91.0-1
kholidays 1:5.90.0-1 -> 1:5.91.0-1
khtml 5.90.0-1 -> 5.91.0-1
ki18n 5.90.0-1 -> 5.91.0-1
kiconthemes 5.90.0-1 -> 5.91.0-1
kidletime 5.90.0-1 -> 5.91.0-1
kio 5.90.0-1 -> 5.91.0-1
kirigami2 5.90.0-1 -> 5.91.0-1
kitemmodels 5.90.0-1 -> 5.91.0-1
kitemviews 5.90.0-1 -> 5.91.0-1
kjobwidgets 5.90.0-1 -> 5.91.0-1
kjs 5.90.0-1 -> 5.91.0-1
knewstuff 5.90.0-1 -> 5.91.0-1
knotifications 5.90.0-1 -> 5.91.0-1
knotifyconfig 5.90.0-1 -> 5.91.0-1
kpackage 5.90.0-1 -> 5.91.0-1
kparts 5.90.0-1 -> 5.91.0-1
kpeople 5.90.0-1 -> 5.91.0-1
kpty 5.90.0-1 -> 5.91.0-1
kquickcharts 5.90.0-1 -> 5.91.0-1
krunner 5.90.0-1 -> 5.91.0-1
kservice 5.90.0-1 -> 5.91.0-1
ktexteditor 5.90.0-2 -> 5.91.0-1
ktextwidgets 5.90.0-1 -> 5.91.0-1
kunitconversion 5.90.0-1 -> 5.91.0-1
kwallet 5.90.0-1 -> 5.91.0-1
kwayland 5.90.0-1 -> 5.91.0-1
kwidgetsaddons 5.90.0-1 -> 5.91.0-1
kwindowsystem 5.90.0-1 -> 5.91.0-1
kxmlgui 5.90.0-1 -> 5.91.0-1
lib32-gcc-libs 11.1.0-3 -> 11.2.0-3
lib32-glibc 2.33-5 -> 2.35-2
libelf 0.186-4 -> 0.186-5
libsysprof-capture 3.42.1-2 -> 3.42.1-3
libtool 2.4.6+42+gb88cebd5-16 -> 2.4.6+59+gb55b1cc8-2
linux 5.16.8.arch1-1 -> 5.16.9.arch1-1
linux-api-headers 5.12.3-1 -> 5.16.8-1
linux-headers 5.16.8.arch1-1 -> 5.16.9.arch1-1
linux-lts 5.15.22-1 -> 5.15.23-1
linux-lts-headers 5.15.22-1 -> 5.15.23-1
man-db 2.10.0-1 -> 2.10.1-1
mariadb-libs 10.6.5-2 -> 10.6.7-1
meson 0.61.1-1 -> 0.61.2-1
modemmanager-qt 5.90.0-1 -> 5.91.0-1
mpfr 4.1.0.p13-1 -> 4.1.0.p13-2
nano 6.0-1 -> 6.1-1
netcdf 4.8.1-1 -> 4.8.1-2
networkmanager-qt 5.90.0-1 -> 5.91.0-1
nvidia-installer-db 2.5.5-1 -> 2.5.6-1
plasma-framework 5.90.0-1 -> 5.91.0-1
prison 5.90.0-1 -> 5.91.0-1
purpose 5.90.0-1 -> 5.91.0-1
qpdf 10.5.0-1 -> 10.6.1-1
qqc2-desktop-style 5.90.0-1 -> 5.91.0-1
solid 5.90.0-1 -> 5.91.0-1
sonnet 5.90.0-1 -> 5.91.0-1
syndication 5.90.0-1 -> 5.91.0-1
syntax-highlighting 5.90.0-1 -> 5.91.0-1
threadweaver 5.90.0-1 -> 5.91.0-1
vala 0.54.6-1 -> 0.54.7-1

Now Linux LTS doesn’t start plasma.
Only Linux will load to desktop.
Conky still doesn’t load, but that’s not really an issue anymore at the moment lol
Seems quit a bit slower than normal as well

I’ve never had an update issue like this before,
kinda uncomfortable in what decision to make.

Is it best to just downgrade again and wait,
or stick around and wait for more updates?

I’m seeing people having other strange issues but have no idea if they are related or not.

I don’t have a solution for you at the moment since these updates just went live today, but I can provide a little bit of context for these updates. The following four links help shed some light on recent changes:

https://www.reddit.com/r/archlinux/comments/smvpkd/update_on_the_toolchain_situation/

And this one just came out today as well:

tl;dr, Arch’s glibc, gcc, and binutils packages were out of date for a while and didn’t have many maintainers working on them. These are crucial system components, so it’s ideal that they are up to date as often as reliably possible. This was recently brought front and center to a lot of Arch users, so the community spoke out, the devs listened, and responded with increasing the amount of maintainer that can work on the toolchain.

As a result of updating the toolchain to the next version from 2.33 -->2.35, a lot of rebuilds will need to take place since this toolchain is a core component. Now this is my first time going through a major toolchain update like this, but if it’s anything like the major python update from earlier this year, things will get sorted out. I wouldn’t advise updating right now unless you really have to, I would just wait a couple days, there’s always a package or two that still needs to be rebuilt that got missed, though that is a rare exception. Anything you have from the AUR will probably have to be rebuilt as well with the updated toolchain, so that will be something to consider as well.

In the meantime, if your confident enough, I would do a downgrade and stand by for a couple days and then try again. If you can live with the current state of your system though, then I would just check for any new updates daily for any possible fixes. As for myself, I will wait a few days, maybe by Friday I will update my system, by then things should be sorted out if they aren’t already.

3 Likes

Thankyou very much, that entire answer you gave is quite helpfull!

When the conky thing happened, I found Easy Downgrade by Date

It doesn’t look like the picture, but still works. :stuck_out_tongue:
Going to go back to 7th and wait till the end of the week like you mentioned.

Your insitefull answer was not only direct but helpful in explaining what is currently happening as well, and I thank you for that!

2 Likes

No worries happy to help. I don’t know if this will be an issue or not for most users, I’m debating if a PSA would be necessary or not, but like I said this is my first time going through a major toolchain update, so it may or may not be that much of an issue, but I always like to ire on the side of caution :wink:

2 Likes

I remember an update awhile back, I’m assuming came through the welcome menu if I remember right it popped up ether saying manual intervention or something similar for whatever was going on at the time.
It was nice to know before going into an update.
I wish I could remember the exact circumstances of how it happened.
Just sayin’
But thankyou again…time to reboot and get my conky back :stuck_out_tongue:

1 Like

I’m fully updated on KDE with even todays updates. Unfortunately i don’t use any Conkys. Never have even tried it.

Not having any issues that i know about. :thinking:

3 Likes

all these 5.91 updates installed this morning. now I can’t user e. g. teams (need it for company cmmunication). Changing settings with edit mode on desktop makes desktop crash.

I need to read the linked article and revert to yesterday’s package versions…

edit: using eos-shifttime and going to Feb 14th made it. Teams running again and Configure Desktop works again, too.

Gonna wait some more days.

Toolchain updates

Important notifications

1 Like

Thanks @joekamprad

this raises two questions for me as I’m quite new to arch based distros:

  1. Is there a (central) site where I can have a brief look whenever very basic updates (plasma, qt, kernel, …)???
  2. are there switches for yay where I can select only a few packages to update? A simple “yay” updates everything, but is there a “yay -Xyz” that shows all updates with numbers to select? Same as if I submit a “yay theme” that lets me select from all packages containing “theme”?

Thanks & regards.

partly updates are not supported for arch packaging system…
So not a good idea to partly update …
Better to wait if major update happen.
To get informed there is arch-news but they do not track changes on Desktop Environment updates or such… But if you are on Plasma p.e. keep yourself informed by checking their webside.

3 Likes

No, but there is this forum here… Usually when there is a problem with an update, people will post about it here. I wouldn’t worry too much about it, though, usually all minor issues with updates get resolved by updating again in a day or two.

No, but you can edit your /etc/pacman.conf and uncomment and add packages to the IgnorePkg list. This is not recommended practice, and it’s certainly not supported, and will cause issues in the long run. But it’s good for delaying a package update temporarily if something is broken with a new version.

It is the nature of Arch Linux to keep rolling, no matter what. Using outdated software on Arch is quite difficult and not really intended. This can create problems for people who have very old hardware, especially NoVidea cards.

1 Like

thanks for your hints…

as long as I don’t mess up my system completely the eos-shifttime (I didn’t know before today) was very helpful… and up to now I only had an issue with wpa-supplicant on another laptop.

This is the tradeoff: either having a very up to date rolling distro vs. a “safer” LTS like my previous X/Kubuntu. But I like Endeavour. And I like to take risks. I even leave home with only 20% battery left on my smartphone :slight_smile:

1 Like

That’s true, but Arch is remarkably robust, things rarely break. It’s a good idea to have more than one kernel installed, just in case. Also, if you have NoVidea graphics, you have to keep an eye out for that. But with compatible hardware, it’s really a very smooth experience, even boring a bit, nothing ever breaks :rofl:

2 Likes

I use VMs for this.

I have testing and stable Arch VMs that I update before my bare metal systems.

Any showstopping issues I can rollback using snapshots and troubleshoot the cause before bare metal updating.

Core updates like the toolchain package bumps affect many packages so it is best to hold off a little while until the dust settles and maintainers have had time to rebuild their packages.

5 Likes

Using VMs to test updates is a great idea, and one of very few ways to always know what to expect.

But I just can’t be bothered with that. I prefer to fix problems on my bare metal system when they occur. I think this takes much less work overall (because updates happen very often, and problems are, at least in my experience, exceptionally rare), and it’s more interesting work, I find problem solving to be more fun than testing stuff. :slight_smile:

4 Likes

The testing VM is more to check what is coming down the pipe, which I find interesting.

I don’t test or troubleshoot in testing though, nearly all of these issues tend to get resolved before hitting stable, particularly the non booting variety.

Me too, I just find troubleshooting (when required) in a VM more effecient time wise. I can multitask.

Makes the actual update quicker, easier, safer, and I can get back to what I was doing faster. Any issues I can continue what I was doing uninterrupted.

Having said all that, showstopping issues are few and far between, especially if you wait a few days after large build dependency package updates land, which I always do.

All of this is predicated on not updating several times a day, 2-3 times a week is more than enough for me.

1 Like

I’m on KDE and i don’t have any issues … at least right now. :wink:

If I read your comment right, why don’t you run LTS with Endeavour?
One of the issues after updating I had was LTS not starting plasma, but Linux did. Was only curious why you weren’t booting to LTS is all.

on a side note:
I am currently downgraded to the 7th of last week and didn’t think there was any issues, however last night I needed something on another drive, it took way longer than it should have to mount, and I can’t delete anything off of it.
Just throwing that out there if anyone had that issue.

The 7th may have been a bit too far, as it messes up firefox profile.

I have a spare LTS kernel in place, but this time it seemed to me as it wasn’t the kernel that caused some “weird things” like not starting ms-teams.

its most likely not KDE either.
Sounds like teams needs a rebuild against the new toolchains. If you have it installed from AUR, chances are good that a simple reinstall with clean build might fix it (of course you need to have all other packages updated for that)

1 Like