[Solved] ISO files not played correctly by VLC in Xfce DE

Hi All,

I run into an interesting problem while trying to play ISO files using VLC (newest version):

If I try to play an ISO file using VLC it does not play properly (no video or garbled picture) under Xfce DE. Symptoms indicate that VLC did not get correct data from the file. This happens when VLC is invoked from CLI OR from a file manager. But the same file plays fine under Lxqt or MATE DE.

Anyone has run into this problem before? I thought if VLC is invoked from a shell the DE should not be a factor (unless when Xfce was installed, somehow it affects the file system?).


same system same hardware? same installed OS?

Same machine, different partitions for Xfce and Lxqt or MATE.
Have not tried installing different DEs on the same OS.

So could be a missing package for the feature to work, you could try to start ISO playing without gui to see if it shows some error…
vlc -vvv --color dvd://file.iso
Could be also that XFCE4 do not mount the ISO automatic and other DE do it

1 Like

Thanks for the debugging tips, @joekamprad.

The log shows that encrypted DVD support is unavailable on Xfce installation, and that was easily fixed by installing the libdvdcss package from yay.

Appreciate your help.