Solved -- INSTALLATION: realtek modules r8168 and r8169

something changed on the most current EndeavourOS ISO, that being how the realtek modules r8168 and r8169 are selected or used.

to the best of my investigation it appears that the r8168 package is installed in newer EndeavourOS installations.

I removed the r8168 package and seem to have “fixed” my system. Now r8169 is selected and I have consistent ethernet network connection after suspend.

https://bbs.archlinux.org/viewtopic.php?id=218172
https://bbs.archlinux.org/viewtopic.php?id=140887

@garybean
I thought that you had this fixed to work after hibernation and resume? I’m not sure what you are asking for now? Are you asking just for an explanation why it changed or is there still a problem?

Is not simple as you think !
I have a Linksys with r8168 but it has been detected as r8169 which brings problems. In doing the inverse of you, it worked…

The bug with Realtec r8168/8169 is not new if you follow the links from @Resiliencia

2 Likes

The only solution that i can offer is to create a service file for suspends & resume. This solution is from a Manjaro forum posting.

1 Like

I have the same chip and i don’t have any issue. Not everyone uses suspend and or hibernation also which is where the issue is coming from. A service file for suspend & resume could fix that issue. I don’t really have any thing else i can offer.

You could find in this forum a lot about it, nothing new !

Almost of the time, users found a solutuon.

The problem is Realtek hardware that have issues with drivers and firmware under Linux.

Ik think we can bring such script to the welkom screen ? @manuel

i think it can count on Broadcom-wl or internally broadcomm firmware asswell…

1 Like

First we must make sure which commands and/or services work.

Actually if someone makes a script and verifies that it works, it should be published here first. Then others with similar issue could test it. If any changes need to be made to the script (like adapter name etc.) then the script should use variables for that.

All in all, without good testing the script/service is not generally useful.

And if it will be a service, then Welcome is not the proper place for it.

3 Likes

We will just call it hidden or invisible. :grin:

1 Like

found the cause of my issue to be the inclusion of the r8168 package in newer EndeavourOS installs.

removing r8168 (and rebooting) returned regular operation.