[SOLVED] How to restore Endeavouros boot!

Hi all!
I installed Fedora next to Endeavouros and Windows.
Now my laptop does not see the Endeavouros bootloader in UEFI BIOS.
UEFI BIOS sees only Fedora and Window loaders.
Fedora’s bootloader (grub) provides a choice of boot:

  1. Fedora
  2. Archlinux
  3. Windows

If you choose to download archlinux, then it will not load.
My disks:

$ sudo fdisk -l

Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors (HDD)
...
 Device        Start      End    Sectors     Size       Type
/dev/sda1          34 1065560063 1065560030 508,1G  Linux file system (btrfs Endeavouros /home)
/dev/sda2  1065560064 1191389183  125829120    60G  Linux file system (ext4 Fedora /root)
/dev/sda3  1921198080 1953523711   32325632  15,4G  Microsoft Recovery Environment
/dev/sda4  1191389184 1921198079  729808896   348G  Linux file system (ext4 Fedora /home)
...
Disk /dev/nvme0n1: 119.24 GiB, 128035676160 bytes, 250069680 sectors (SSD)
...
 Device            Start      End    Sectors   Size       Type
/dev/nvme0n1p1      2048    616447    614400   300M EFI
/dev/nvme0n1p2    616448    878591    262144   128M Microsoft Reserved Partition
/dev/nvme0n1p3    878592 143366143 142487552  67,9G Microsoft basic data
/dev/nvme0n1p4 143366144 151754751   8388608     4G Linux swap
/dev/nvme0n1p5 248225792 250068991   1843200   900M Microsoft Recovery Environment
/dev/nvme0n1p6 151754752 248225791  96471040    46G Linux file system (btrfs Endeavouros /root)

When installing Fedora, pointed /boot/efi to /dev/nvme0n1p1.
I think Fedora bootloader cannot load Endeavouros because /root partition Endeavouros has btrfs filesystem.

Question!
How do I repair the Endeavouros bootloader?
How do I force the fedora bootloader to load Endeavouros?
Please, help!
Endeavouros is my main system!

main is fedora?

mayby check https://fedoraproject.org/wiki/GRUB_2#Adding_Other_operating_systems_to_the_GRUB_2_menu ?

Welcome aboard!
It looks like you have way more than what you have stated going on here.

That should not be there.

It looks like you were attempting to dual boot Win and fedora on the NVME and have EndeavourOS on the SSD. Windows often wreaks havok on EFI partitions when dual booting. I never do it so I am not sure. At the very least you should have disconnected the EndeavourOS drive before attempting the dual boot of fedora and win.

1 Like
/dev/sda3  1921198080 1953523711   32325632  15,4G  Microsoft Recovery Environment

This section was already there when I bought my laptop with Window 10 installed
I didn’t create it.
I thought he was needed for correct Windows operation

You have no CD its needed if you reinstall windows… thats basicly oem are. early computing you get cd’s or floppy to your pc but now it isnt… is the backup top restore windows :slight_smile:

Keep an eye on this post you could maybe just repair your win 10 boot without reinstalling all depending what you did !

Windows 10 is fine, it boots

Is this where you had installed EnOS’ bootloader previously as well?

Maybe you could check the content of /boo/efi/EFI from Fedora to see if you have the folder EndeavourOS with grubx64.efi inside.

If you don’t, I guess you would need to reinstall EnOS’ bootloader.

Perhaps also post the output of efibootmgr -v.

looks like on installing fedora, you set it up to take over boot, and it does not detect eos in a working way. you can solve this in different ways

Sorry, I reread better…but we agreed that your Fedora is your main distro for now and you want EndeavourOs to be your main system ?

efibootmgr -v
BootCurrent: 0008
Timeout: 1 seconds
BootOrder: 0008,0000,0004,0002,0003,0007,0005
Boot0000* Windows Boot Manager	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...,................
Boot0002  ubuntu	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\UBUNTU\SHIMX64.EFI)..BO
Boot0003  Fedora	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\FEDORA\SHIM.EFI)..BO
Boot0004  opensuse	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\OPENSUSE\GRUBX64.EFI)..BO
Boot0005  debian	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\DEBIAN\GRUBX64.EFI)..BO
Boot0007  Linux Boot Manager	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\SYSTEMD\SYSTEMD-BOOTX64.EFI)
Boot0008* Fedora	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\FEDORA\SHIM.EFI)..BO

ubuntu, opensuse, debian, Linux Boot Manager (Solus) they are gone i tried to delete them
efibootmgr -b xxxx -B
but they didn’t leave
All these distributions were installed with the bootloader installed in /dev/nvme0n1p1
I don’t understand why Fedora has two entries
I installed only once

EndeavourOs - Main sistem

1 Like
$ sudo ls /boot/efi/EFI
antergos  antergos_grub  antergos_grub_0arl  antergos_grub_88iy  antergos_grub_omd6  antergos_grub_opcd  ArchLabs  Boot  com.solus-project  Ctlos  debian  EndeavourOS	fedora	grub  Manjaro  Microsoft  opensuse  systemd  ubuntu
EndeavourOS in /boot/efi/EFI
1 Like

If it indeed contains grubx64.efi (which it should), you could try to create a boot entry by running:

sudo efibootmgr -c -d /dev/nvme0n1 -p 1 -w -L EnOS -l "\EFI\EndeavourOS\grubx64.efi"

I hope this will solve the problem. If it doesn’t I am afraid I can’t be of much more help.

Did you use sudo ?

I’m scared )

No!

:hugs:

You shouldn’t be. That is how you could create an efi boot entry manually.
If it won’t work remove the “quotes” and try again.

You should be using sudo for that command to work. Clean up the unneeded boot entries first and then create a new one for EnOS.

Please be careful not deleting a boot entry that you need.

1 Like

When you tried to delete older boot like 0004,0002,0003,0005 that you don’t need anymore with the efibootmgr show me what you used exactly for example if you delete open suse ?

I did it!

efibootmgr -v
BootCurrent: 0008
Timeout: 1 seconds
BootOrder: 0001,0008,0000,0003
Boot0000* Windows Boot Manager	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...,................
Boot0001* EndeavourOS	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(ࠜEFIEndeavourOSgrubx64.efi)
Boot0003  Fedora	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\FEDORA\SHIM.EFI)..BO
Boot0008* Fedora	HD(1,GPT,5f774f65-6102-4e95-9fe0-06fb49f7d6e1,0x800,0x96000)/File(\EFI\FEDORA\SHIM.EFI)..BO

Why fedora twice?

I need to do this grub2-mkconfig -o /boot/grub2/grub.cfg before rebooting the system?